summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMatthew James Kraai <kraai@ftbfs.org>2022-10-26 04:28:48 -0700
committerChristopher Baines <mail@cbaines.net>2022-11-05 11:37:19 +0100
commitf56aae998cf4d90660e3c758c934990ec30c4776 (patch)
tree373a1d02b28f26cd66159488d161bc042c8fe92e /gnu
parent2b004b4ed0f1c6b16fa6c8bf0cbb3325538cf398 (diff)
downloadguix-f56aae998cf4d90660e3c758c934990ec30c4776.tar.gz
gnu: Add tasksh.
* gnu/packages/task-management.scm (tasksh): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/task-management.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/task-management.scm b/gnu/packages/task-management.scm
index c0b3cd963c..cb5cc6ff0d 100644
--- a/gnu/packages/task-management.scm
+++ b/gnu/packages/task-management.scm
@@ -8,6 +8,7 @@
 ;;; Copyright © 2021 Reza Alizadeh Majd <r.majd@pantherx.org>
 ;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
 ;;; Copyright © 2022 Pavel Shlyak <p.shlyak@pantherx.org>
+;;; Copyright © 2022 Matthew James Kraai <kraai@ftbfs.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -44,6 +45,7 @@
   #:use-module (gnu packages python-build)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages qt)
+  #:use-module (gnu packages readline)
   #:use-module (gnu packages time)
   #:use-module (gnu packages tls)
   #:use-module (guix download)
@@ -152,6 +154,33 @@ Done time management method.  It supports network synchronization, filtering
 and querying data, exposing task data in multiple formats to other tools.")
     (license license:expat)))
 
+(define-public tasksh
+  (package
+    (name "tasksh")
+    (version "1.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://taskwarrior.org/download/tasksh-" version ".tar.gz"))
+       (sha256 (base32
+                "1z8zw8lld62fjafjvy248dncjk0i4fwygw0ahzjdvyyppx4zjhkf"))))
+    (build-system cmake-build-system)
+    (inputs
+     (list readline))
+    (arguments
+     `(#:tests? #f ; No tests implemented.
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'install-license-files)))) ; Already installed by package
+    (home-page "https://taskwarrior.org")
+    (synopsis "Taskwarrior shell")
+    (description
+     "Tasksh is a shell for Taskwarrior, providing a more immersive
+environment for list management. It has a review feature, shell command
+execution, and libreadline support.")
+    (license license:expat)))
+
 (define-public worklog
   (let ((commit "0f545ad6697ef4de7f68d92cd7cc5c6a4c60517b")
         (revision "1"))