summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-10-15 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-10-15 02:00:00 +0200
commitf59bbf0a97b1d35a37c003f547ead11729d76c4c (patch)
treeaed7264683627d288194e8c2be3c043848063d14 /gnu
parent063655dbada4ec95b59bd94edded61b664528fcb (diff)
downloadguix-f59bbf0a97b1d35a37c003f547ead11729d76c4c.tar.gz
gnu: mosh: Prepare for cross-building.
Currently blocked by protobuf.

* gnu/packages/ssh.scm (mosh)[arguments]: Use SEARCH-INPUT-FILE.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ssh.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 39b90fad8f..2434a563c2 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -477,10 +477,10 @@ with optional @acronym{TLS, Transport-Level Security} to protect credentials.")
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'unpack 'patch-FHS-file-names
-            (lambda _
+            (lambda* (#:key inputs #:allow-other-keys)
               (substitute* "scripts/mosh.pl"
-                (("/bin/sh")
-                 (which "sh")))))
+                (("/bin/sh" shell)
+                 (search-input-file inputs shell)))))
           (add-after 'install 'wrap
             (lambda _
               ;; Make sure 'mosh' can find 'mosh-client' and 'mosh-server'.