summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-04-27 13:07:13 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-05-02 14:34:37 +0300
commitf59cc03b569ec7b2d96cdd5474685984640fc074 (patch)
treee8c0df16acb86ddfd51a94ecb7be3c4f2d1fe8a4 /gnu
parent7c65fc378cf68b598965fd977f5844050435ac97 (diff)
downloadguix-f59cc03b569ec7b2d96cdd5474685984640fc074.tar.gz
gnu: Add emacs-gitlab-snip-helm.
* gnu/packages/emacs-xyz.scm (emacs-gitlab-snip-helm): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d9a3c2acc3..cb9405acf0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7515,6 +7515,29 @@ special variables.  An interface to GitLab’s CI file linter is also provided
 via @code{gitlab-ci-lint}.")
     (license license:gpl3+)))
 
+(define-public emacs-gitlab-snip-helm
+  (package
+    (name "emacs-gitlab-snip-helm")
+    (version "0.0.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.com/sasanidas/gitlab-snip-helm.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1c5js19zyb1z61hapvbfcl5jhrjqij46cxldgqij6al0scw44dga"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-dash" ,emacs-dash)
+       ("emacs-helm" ,emacs-helm)))
+    (home-page "https://gitlab.com/sasanidas/gitlab-snip-helm/")
+    (synopsis "GitLab snippet API interaction for Emacs")
+    (description "This package provides GitLab snippet API interaction for
+Emacs.")
+    (license license:gpl3+)))
+
 (define-public emacs-web-mode
   (package
     (name "emacs-web-mode")