summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-04-05 16:27:33 +0200
committerAndreas Enge <andreas@enge.fr>2023-04-05 16:29:27 +0200
commitf59d94d236d3ca8bcb8bda1280452d4541d28d75 (patch)
tree10d8f4a4558a4e1971b44daadb2767e0ad35d65e /gnu
parenta0cf2bb5f1d28b636574fb6b974dd7ba1ded6d2d (diff)
downloadguix-f59d94d236d3ca8bcb8bda1280452d4541d28d75.tar.gz
gnu: cdrdao: Update to 1.2.5.
This also fixes a hash mismatch in the previous version.

* gnu/packages/cdrom.scm (cdrdao): Update to 1.2.5.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cdrom.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index cfb2b6b686..13f01870d2 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -250,7 +250,7 @@ reconstruction capability.")
 (define-public cdrdao
   (package
     (name "cdrdao")
-    (version "1.2.4")
+    (version "1.2.5")
     (source
      (origin
        (method git-fetch)
@@ -260,7 +260,7 @@ reconstruction capability.")
               (string-append "rel_" (string-replace-substring version "." "_")))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1gcl8ibyylamy2d1piq3749nw3xrlp12r0spzp2gmni57b8a6b7j"))))
+        (base32 "1hh1lm4wr1vhsq2brczn94h88h3bppvjidj9cfqkl20jhaj38968"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags
@@ -274,9 +274,12 @@ reconstruction capability.")
        (modify-phases %standard-phases
          (add-before 'bootstrap 'fix-configure.ac
            (lambda _
-             ;; Remove reference to missing macro.
-             (substitute* "configure.ac" (("^AM_GCONF_SOURCE_2.*") ""))
-             #t)))))
+             ;; Remove references to missing macros.
+             (substitute* "configure.ac"
+              (("^AM_GCONF_SOURCE_2.*") "")
+              ;; This was introduced in autoconf-2.70, but is described
+              ;; as usually not needed in the autoconf documentation.
+              (("^AC_CHECK_INCLUDES_DEFAULT") "")))))))
     (native-inputs
      (list autoconf automake pkg-config))
     (inputs