summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorIan Eure <ian@retrospec.tv>2023-11-21 14:32:32 -0800
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-01-04 12:32:52 +0100
commitf65e3ec0dfd250cbd56c3f3b508ee62d50bd7771 (patch)
tree97f2c69848b7300ab1809f990f12e216250370c6 /gnu
parentc7f133957507c92e50ae15e3b0bc8e7414461350 (diff)
downloadguix-f65e3ec0dfd250cbd56c3f3b508ee62d50bd7771.tar.gz
gnu: Add emacs-sql-indent.
* gnu/packages/emacs-xyz.scm (emacs-sql-indent): New variable.

Change-Id: I56a5f1c2e5256ed2ebcfe58ff99faffe49bf8519
Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 39aab1b8c2..bce4191ae1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22596,6 +22596,26 @@ objects.  All objects have to share a common superclass and subclasses cannot
 add any additional instance slots.")
     (license license:gpl3)))
 
+(define-public emacs-sql-indent
+  (package
+    (name "emacs-sql-indent")
+    (version "1.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://elpa.gnu.org/packages/sql-indent-" version
+                           ".tar"))
+       (sha256
+        (base32 "043qcy97a5hx68w0ac7xsk380l2i7bphgrdz6aby2zfpp90vrjpn"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/alex-hhh/emacs-sql-indent")
+    (synopsis "Support for indenting code in SQL files")
+    (description
+     "This package provides a minor mode that enables syntax-based indentation
+for SQL mode buffers.  Indentation rules are flexible and can be customized to
+match your personal coding style.")
+    (license license:gpl3+)))
+
 (define-public emacs-epkg
   (package
     (name "emacs-epkg")