summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-22 19:19:19 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-11 21:58:25 +0200
commitf77d82f105b6c2e560e2ee3e5049a5d9a314f0c4 (patch)
treebde4fa8728f39e56085082d79b54f5a2ef3349e8 /gnu
parent9f4a3059615350aee66f2fd19887505b1a50fe78 (diff)
downloadguix-f77d82f105b6c2e560e2ee3e5049a5d9a314f0c4.tar.gz
gnu: Add python-django-statici18n.
* gnu/packages/django.scm (python-django-statici18n, python2-django-statici18n):
New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/django.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 0a6a7e4256..fe93573030 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -598,3 +598,27 @@ name is purely coincidental.")
 
 (define-public python2-django-appconf
   (package-with-python2 python-django-appconf))
+
+(define-public python-django-statici18n
+  (package
+    (name "python-django-statici18n")
+    (version "1.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "django-statici18n" version))
+              (sha256
+               (base32
+                "0alcf4g1nv69njhq5k3qw4mfl2k6dc18bik5nk0g1mnp3m8zyz7k"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-django" ,python-django)
+       ("django-appconf" ,python-django-appconf)))
+    (home-page "https://github.com/zyegfryed/django-statici18n")
+    (synopsis "Generate JavaScript catalog to static files")
+    (description
+      "A Django app that provides helper for generating JavaScript catalog to
+static files.")
+    (license license:bsd-3)))
+
+(define-public python2-django-statici18n
+  (package-with-python2 python-django-statici18n))