summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTheodoros Foradis <theodoros@foradis.org>2018-07-08 20:39:32 +0300
committerLudovic Courtès <ludo@gnu.org>2018-07-16 16:47:05 +0200
commitf7e248396ba698b7de99414039d9db02050bc7d3 (patch)
treee998a4c16f346c60055cd72499079ea9515dcda8 /gnu
parent88d5ee44ed6aae7015691a2a3255132c263b5fa9 (diff)
downloadguix-f7e248396ba698b7de99414039d9db02050bc7d3.tar.gz
gnu: monero-core: Rename package to "monero-gui".
* gnu/packages/finance.scm (monero-core): Define in terms of
'deprecated-package'.
(monero-gui): New variable, formerly known as "monero-core".

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/finance.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index e1623020a3..7b3706d30c 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -460,15 +460,15 @@ other machines/servers.  Electroncash does not download the Bitcoin Cash blockch
 Monero command line client and daemon.")
     (license license:bsd-3)))
 
-(define-public monero-core
+(define-public monero-gui
   (package
-    (name "monero-core")
+    (name "monero-gui")
     (version "0.12.2.0")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/monero-project/monero-core")
+             (url "https://github.com/monero-project/monero-gui")
              (commit (string-append "v" version))))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
@@ -537,6 +537,9 @@ Monero command line client and daemon.")
 Monero GUI client.")
     (license license:bsd-3)))
 
+(define-public monero-core
+  (deprecated-package "monero-core" monero-gui))
+
 (define-public python-trezor-agent
   (package
     (name "python-trezor-agent")