summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-11-05 18:52:38 +0100
committerDavid Craven <david@craven.ch>2016-12-10 21:47:07 +0100
commitf7e624b639c24c5d4a374ff92b134375ecfdee92 (patch)
treeac26b3ae4adc0bc23b98a89bb068565fd5d9ee14 /gnu
parentb7f96285a5dcb69028344ee448ef1054a0287cd4 (diff)
downloadguix-f7e624b639c24c5d4a374ff92b134375ecfdee92.tar.gz
gnu: Add ghc-tasty-rerun.
* gnu/packages/haskell.scm (ghc-tasty-rerun): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 4a69dc3eb9..7b46aad340 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8043,4 +8043,33 @@ deletion notification. This library builds upon existing libraries for platform
 specific Windows, Mac, and Linux filesystem event notification.")
     (license license:bsd-3)))
 
+(define-public ghc-tasty-rerun
+  (package
+    (name "ghc-tasty-rerun")
+    (version "1.1.6")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://hackage.haskell.org/package/tasty-rerun/"
+                    "tasty-rerun-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0ycxg7whabgcxyzy6gr536x8ykzx45whh1wrbsc7c58zi862fczd"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-mtl" ,ghc-mtl)
+       ("ghc-optparse-applicative" ,ghc-optparse-applicative)
+       ("ghc-reducers" ,ghc-reducers)
+       ("ghc-split" ,ghc-split)
+       ("ghc-stm" ,ghc-stm)
+       ("ghc-tagged" ,ghc-tagged)
+       ("ghc-tasty" ,ghc-tasty)))
+    (home-page "http://github.com/ocharles/tasty-rerun")
+    (synopsis "Run tests by filtering the test tree")
+    (description "This package adds the ability to run tests by filtering the
+test tree based on the result of a previous test run.  You can use this to run
+only those tests that failed in the last run, or to only run the tests that have
+been added since previous test run.")
+  (license license:bsd-3)))
+
 ;;; haskell.scm ends here