summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-11-19 09:15:58 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-11-19 09:15:58 +0200
commitf7ef5a7f46b4131723014e80d48491cee58cbb9c (patch)
tree396c6f8dcbe6436be27863589130de9702c57082 /gnu
parentb7abea0fd6a146563830db1dc4ddd0cceb6fcf1c (diff)
downloadguix-f7ef5a7f46b4131723014e80d48491cee58cbb9c.tar.gz
gnu: tbb: Fix building on powerpc-linux.
* gnu/packages/tbb.scm (tbb)[arguments]: Adjust configure-flags when
building for powerpc-linux to always link to libatomic and use the low
resources tests.  When building for powerpc-linux skip 3 tests.

Change-Id: I323db085db1fcbb33f96c2bccb85cb8f56d41f6b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tbb.scm29
1 files changed, 20 insertions, 9 deletions
diff --git a/gnu/packages/tbb.scm b/gnu/packages/tbb.scm
index b73ff22e48..ec630a029f 100644
--- a/gnu/packages/tbb.scm
+++ b/gnu/packages/tbb.scm
@@ -49,22 +49,33 @@
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags
-       '(,@(if (target-riscv64?)
+       '(,@(if (or (target-riscv64?)
+                   (target-ppc32?))
             '("-DTBB_TEST_LINK_FLAGS=-latomic")
             `())
-         ,@(if (target-arm32?)
+         ,@(if (or (target-arm32?)
+                   (target-ppc32?))
              '("-DTBB_TEST_COMPILE_FLAGS=-DTBB_TEST_LOW_WORKLOAD")
              `())
          "-DTBB_STRICT=OFF")   ;; Don't fail on warnings
        #:phases
        (modify-phases %standard-phases
-         ,@(if (target-arm32?)
-             `((add-after 'unpack 'adjust-test-suite
-                 (lambda _
-                   (substitute* "test/CMakeLists.txt"
-                     ;; Bus error, skipped on mips.
-                     ((".*test_malloc_pools.*") "")))))
-             '()))))
+         ,@(cond
+             ((target-arm32?)
+              `((add-after 'unpack 'adjust-test-suite
+                  (lambda _
+                    (substitute* "test/CMakeLists.txt"
+                      ;; Bus error, skipped on mips.
+                      ((".*test_malloc_pools.*") ""))))))
+             ((target-ppc32?)
+              `((add-after 'unpack 'adjust-test-suite
+                  (lambda _
+                      (substitute* "test/CMakeLists.txt"
+                        ;; These tests hang forever.
+                        ((".*test_function_node.*") "")
+                        ((".*test_multifunction_node.*") "")
+                        ((".*test_async_node.*") ""))))))
+             (else '())))))
     (home-page "https://www.threadingbuildingblocks.org")
     (synopsis "C++ library for parallel programming")
     (description