summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-07 11:29:20 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-03-07 13:04:26 +0200
commitf7fcddef52e5d167922e0225a3a22c900a14cb5b (patch)
tree574bdd24d9b6afefa5916614d71dc80eea2293e9 /gnu
parentf7295486ac22ba51904b10bbedd518390c81ac57 (diff)
downloadguix-f7fcddef52e5d167922e0225a3a22c900a14cb5b.tar.gz
gnu: Add guix-backgrounds.
* gnu/packages/package-management.scm (guix-backgrounds): New variable.

Change-Id: If6159ed955877c42452b5ab6d853d3bf8687cde0
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/package-management.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index f392c737fe..c40f90ecfc 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -120,6 +120,7 @@
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages version-control)
   #:autoload   (guix build-system channel) (channel-build-system)
+  #:use-module (guix build-system copy)
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system guile)
@@ -742,6 +743,23 @@ the Icon Theme Specification.  They can be used by applications querying the
 GTK icon cache for instance.")
     (license license:cc-by-sa4.0)))
 
+(define-public guix-backgrounds
+  (package
+    (name "guix-backgrounds")
+    (version "0.1")
+    (source %artwork-repository)
+    (build-system copy-build-system)
+    (arguments
+     (list #:install-plan
+           #~'(("backgrounds" "share/backgrounds/guix" #:exclude ("README")))))
+    (home-page "https://www.gnu.org/software/guix/")
+    (synopsis "Background images for GNU Guix")
+    (description "The SVG files in this directory are intended to be used as
+backgrounds for different components of the GNU system like login managers and
+desktop environments.  The backgrounds are available in different aspect ratios
+which are indicated in the file name.")
+    (license (list license:public-domain license:cc-by-sa4.0))))
+
 (define-public guix-modules
   (package
     (name "guix-modules")