summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 15:37:24 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:22 +0200
commitf802c5857f3f8c16a40572d1fed008f344abd801 (patch)
treee790118fc50129d48970503e2fb86b654f1b61e1 /gnu
parenta4d7679a5e8944f8de28965ef5ba0d617dcc3c62 (diff)
downloadguix-f802c5857f3f8c16a40572d1fed008f344abd801.tar.gz
gnu: Add texlive-clrscode3e.
* gnu/packages/tex.scm (texlive-clrscode3e): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2c560234fa..7398bfea8c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2526,6 +2526,28 @@ commands the same way the package's author did when writing the book, and your
 output will look just like the pseudocode in the text.")
     (license license:lppl)))
 
+(define-public texlive-clrscode3e
+  (package
+    (name "texlive-clrscode3e")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/clrscode3e/"
+                   "tex/latex/clrscode3e/")
+             (base32
+              "1kcsrlvqs83fc9ianim3drqvz60xp2cfl6a554icnm39p1fjf80c")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/clrscode3e")
+    (synopsis "Typesets pseudocode as in @emph{Introduction to Algorithms}")
+    (description
+     "This package allows you to typeset pseudocode in the style of
+@emph{Introduction to Algorithms}, Third edition, by Cormen, Leiserson,
+Rivest, and Stein.  The package was written by the authors.  Use the commands
+the same way the package's author did when writing the book, and your output
+will look just like the pseudocode in the text.")
+    (license license:lppl)))
+
 (define-public texlive-colorsep
   (package
     (name "texlive-colorsep")