summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2023-12-30 21:20:43 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-12 22:12:19 +0000
commitf847b47be0b2be480d74685b11fac42babfd41d2 (patch)
treebd5bfa2df4bdd938da3fdad7e7216dcff5f8adca /gnu
parentbfdcf6b36578ac0567f7e06651375d74688d22e5 (diff)
downloadguix-f847b47be0b2be480d74685b11fac42babfd41d2.tar.gz
gnu: Add go-github-com-google-btree.
* gnu/packages/golang.scm (go-github-com-google-btree): New variable.

Change-Id: Ibe7ce2c457153e40539bb26e0fcaf0bec79ed253
Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c68f26bf42..060a6b2583 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12030,6 +12030,29 @@ implementation.")
 using shell-style rules for quoting and commenting.")
     (license license:asl2.0)))
 
+(define-public go-github-com-google-btree
+  (package
+    (name "go-github-com-google-btree")
+    (version "1.1.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/google/btree")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0cqa8ck26p3wqz877hcvmfss17xm8wcbwd68shxv795ppahpdd9b"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/google/btree"))
+    (home-page "https://github.com/google/btree")
+    (synopsis "Simple, ordered, in-memory data structure for Go programs")
+    (description
+     "This package provides an in-memory B-Tree implementation for Go, useful as an
+ordered, mutable data structure.")
+    (license license:asl2.0)))
+
 (define-public go-github-com-disintegration-imaging
   (package
     (name "go-github-com-disintegration-imaging")