summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:24:12 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:49:31 +0200
commitf84fe09bb4fcab02bfbcaf4f5b4e50628e903581 (patch)
tree51be9fc36cfb4c85dfdfad9273c20f949c74d717 /gnu
parentb555dfe7449f3f75282a1ccf234c47b6c31e6bbb (diff)
downloadguix-f84fe09bb4fcab02bfbcaf4f5b4e50628e903581.tar.gz
gnu: Add texlive-skaknew.
* gnu/packages/tex.scm (texlive-skaknew): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index df4073194e..96e3faecf3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -13241,6 +13241,29 @@ available in package @code{texmate}, and a general mechanism for selecting
 chess fonts is provided in @code{chessfss}.")
     (license license:lppl)))
 
+(define-public texlive-skaknew
+  (package
+    (name "texlive-skaknew")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/skaknew/"
+                   "fonts/afm/public/skaknew/"
+                   "fonts/map/dvips/skaknew/"
+                   "fonts/opentype/public/skaknew/"
+                   "fonts/tfm/public/skaknew/"
+                   "fonts/type1/public/skaknew/")
+             (base32
+              "1jpm36qb65jbsrhq1yqhwajqz3jg35wid0wlav9hk7q4hd58qi4r")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/skaknew")
+    (synopsis "The @code{skak} chess fonts redone in Adobe Type 1")
+    (description
+     "This package offers Adobe Type 1 versions of the fonts provided as
+Metafont source by the @code{skak} bundle.")
+    (license license:lppl)))
+
 (define-public texlive-skmath
   (package
     (name "texlive-skmath")