summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 15:52:12 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:31 +0200
commitf88398ed5089faddec79fe09c2adff2cda17e97a (patch)
treeb75da729216eb243da0d94504ad7d9692b06073d /gnu
parentfc0f5676c6606693180f83ebad8fe87c91b370b2 (diff)
downloadguix-f88398ed5089faddec79fe09c2adff2cda17e97a.tar.gz
gnu: Add texlive-easing.
* gnu/packages/tex.scm (texlive-easing): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3b61643cf6..f22579dfaa 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3265,6 +3265,24 @@ simple roots.")
     ;; LGPL 2.1+.
     (license license:lgpl2.1+)))
 
+(define-public texlive-easing
+  (package
+    (name "texlive-easing")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin name version
+                            (list "doc/latex/easing/" "source/latex/easing/"
+                                  "tex/latex/easing/")
+                            (base32
+                             "1j6y1i6cz7pcgrd6pisk6f11r30lrr4cnbhhdshl48wp97byjnw4")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/easing")
+    (synopsis "Easing functions for @code{pgfmath}")
+    (description
+     "This library implements a collection of easing functions and adds them
+to the PGF mathematical engine.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")