summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-28 16:23:09 +0000
committerChristopher Baines <mail@cbaines.net>2019-02-14 21:38:02 +0000
commitf9da1ada2308718a64deb44f0ebda0cbe2a31fa5 (patch)
treeac3330be042465fee0695fd6b805ccedee624497 /gnu
parent937c8862f493aea2ae167851ecc22b03fd0d1d04 (diff)
downloadguix-f9da1ada2308718a64deb44f0ebda0cbe2a31fa5.tar.gz
gnu: Add ruby-globalid.
Required for ruby-activejob.

* gnu/packages/ruby.scm (ruby-globalid): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 1071460efc..38d462eeda 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7533,3 +7533,27 @@ interface over different adapters.")
 for scalable network clients and servers.")
    (home-page "https://github.com/socketry/nio4r")
    (license license:expat)))
+
+(define-public ruby-globalid
+  (package
+   (name "ruby-globalid")
+   (version "0.4.2")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (rubygems-uri "globalid" version))
+     (sha256
+      (base32
+       "1zkxndvck72bfw235bd9nl2ii0lvs5z88q14706cmn702ww2mxv1"))))
+   (build-system ruby-build-system)
+   (arguments
+    '(;; No included tests
+      #:tests? #f))
+   (propagated-inputs
+    `(("ruby-activesupport" ,ruby-activesupport)))
+   (synopsis "Generate URIs idenfitying model instances in Ruby")
+   (description
+    "@code{GlobalID} provides a way to generate URIs from a model in Ruby that
+uniquely identify it.")
+   (home-page "https://rubyonrails.org/")
+   (license license:expat)))