summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:34:48 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:15 -0500
commitfae3b9d5988393e5385c5d3d067b1412fd1044a2 (patch)
tree8e44e929286f61c82243001cf4300f0e6b59b1cf /gnu
parente0060729b5dfa678bd686ad20435485a73f3d4d0 (diff)
downloadguix-fae3b9d5988393e5385c5d3d067b1412fd1044a2.tar.gz
gnu: go-github-com-gorilla-handlers: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-gorilla-handlers): Move from
here...
* gnu/packages/golang-web.scm: ...to here.

* gnu/packages/backup.scm: Add (gnu packages golang-web) module.

Change-Id: I7535bdecc681e230f4aee70115a3dea847d40e6f
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/backup.scm1
-rw-r--r--gnu/packages/golang-web.scm28
-rw-r--r--gnu/packages/golang.scm26
3 files changed, 28 insertions, 27 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 58c071e1fa..3126464347 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -71,6 +71,7 @@
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages golang)
+  #:use-module (gnu packages golang-web)
   #:use-module (gnu packages gperf)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages guile)
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index f9e7039707..0480f648eb 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1,9 +1,10 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
 ;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
+;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
-;;; Copyright © 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
+;;; Copyright © 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2022 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2022 muradm <mail@muradm.net>
 ;;;
@@ -139,6 +140,31 @@ the parse trees produced by the html package.")
     (description "This package provides a CSS3 tokenizer.")
     (license license:bsd-3)))
 
+(define-public go-github-com-gorilla-handlers
+  (package
+    (name "go-github-com-gorilla-handlers")
+    (version "1.5.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/gorilla/handlers")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "15gycdz9lkjnsvvichsbdf25vf6pi1sfn41khhz53iqf300l0w0s"))))
+    (build-system go-build-system)
+    (propagated-inputs
+     `(("github.com/felixge/httpsnoop" ,go-github-com-felixge-httpsnoop)))
+    (arguments
+     '(#:tests? #f                      ; Tries to download from the internet
+       #:import-path "github.com/gorilla/handlers"))
+    (home-page "https://github.com/gorilla/handlers")
+    (synopsis "Middleware for Go HTTP services and web applications")
+    (description "A collection of useful middleware for Go HTTP services and
+web applications.")
+    (license license:bsd-3)))
+
 (define-public go-github-com-gorilla-mux
   (package
     (name "go-github-com-gorilla-mux")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f51d8fd455..fb826c2743 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4867,32 +4867,6 @@ the @code{c2go} tool at
 @url{https://github.com/andybalholm/c2go,https://github.com/andybalholm/c2go}.")
     (license license:expat)))
 
-(define-public go-github-com-gorilla-handlers
-  (package
-    (name "go-github-com-gorilla-handlers")
-    (version "1.5.1")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/gorilla/handlers")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32
-         "15gycdz9lkjnsvvichsbdf25vf6pi1sfn41khhz53iqf300l0w0s"))))
-    (build-system go-build-system)
-    (propagated-inputs
-     `(("github.com/felixge/httpsnoop" ,go-github-com-felixge-httpsnoop)))
-    (arguments
-     '(#:tests? #f                      ; Tries to download from the internet
-       #:import-path "github.com/gorilla/handlers"))
-    (home-page "https://github.com/gorilla/handlers")
-    (synopsis "Middleware for Go HTTP services and web applications")
-    (description "A collection of useful middleware for Go HTTP services
-and web applications.")
-    (license license:bsd-3)))
-
 (define-public go-github-com-gorilla-securecookie
   (package
     (name "go-github-com-gorilla-securecookie")