summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-08 02:00:10 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-08 02:00:01 +0200
commitfaf715b1dcf9a7d984846f43c2110de2d4b896ff (patch)
tree5e555b7bee091b8d0d6a73ff3e8588022d5866a4 /gnu
parent20fbd870938e239c038d8524a56729f123f19f80 (diff)
downloadguix-faf715b1dcf9a7d984846f43c2110de2d4b896ff.tar.gz
gnu: lighttpd: Fix bash reference.
* gnu/packages/web.scm (lighttpd)[arguments]:
Substitute SEARCH-INPUT-FILE for WHICH.
[inputs]: Add bash-minimal.

f fix lighttpd xcc
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index bc913664e3..fabe488c2a 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -16,7 +16,7 @@
 ;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
 ;;; Copyright © 2016, 2017, 2018, 2019, 2021 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2016–2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016–2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2016 Bake Timmons <b3timmons@speedymail.org>
 ;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
 ;;; Copyright © 2017, 2018, 2020, 2021, 2022 Marius Bakke <marius@gnu.org>
@@ -849,9 +849,9 @@ stream.  Remote control of the module is possible over HTTP.")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'embed-/bin/sh-reference
-           (lambda _
+           (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "src/mod_ssi.c"
-               (("/bin/sh") (which "sh")))
+               (("/bin/sh") (search-input-file inputs "/bin/sh")))
              #t))
          (add-after 'unpack 'fix-tests
            (lambda _
@@ -862,7 +862,8 @@ stream.  Remote control of the module is possible over HTTP.")
                 "{HOSTNAME} = \"127.0.0.1\";"))
              #t)))))
     (inputs
-     `(("cyrus-sasl" ,cyrus-sasl)
+     `(("bash-minimal" ,bash-minimal)
+       ("cyrus-sasl" ,cyrus-sasl)
        ("libev" ,libev)
        ("libunwind" ,libunwind)
        ("linux-pam" ,linux-pam)