summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-07 21:18:45 +0200
committerDavid Craven <david@craven.ch>2016-08-30 22:38:28 +0200
commitfb748c395d7d0bd69161faf86ce70891ba4c2fe2 (patch)
tree570f6c48ee9c8450e94f814c45776dfc9a1c98c6 /gnu
parent88549d2e0c8ab9c9fce221f973bb9102db61f9fc (diff)
downloadguix-fb748c395d7d0bd69161faf86ce70891ba4c2fe2.tar.gz
gnu: Add kactivities-stats.
* gnu/packages/kde-frameworks.scm (kactivities-stats): New variable.

Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 90c7be6b50..6503cdcf6c 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1571,3 +1571,35 @@ daemon, a library for interacting with that daemon, and plugins for integration
 with other frameworks.")
     ;; triple licensed
     (license (list license:gpl2+ license:lgpl2.0+ license:lgpl2.1+))))
+
+;; NOTE: This package is listed as a tier 2 package even though it requires
+;;       kactivities - a tier 3 package.
+(define-public kactivities-stats
+  (package
+    (name "kactivities-stats")
+    (version "5.24.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/frameworks/"
+                           (version-major+minor version) "/"
+                           name "-" version ".tar.xz"))
+       (sha256
+        (base32
+         "1z3xvpifxbd05b2xaxxyiypcpid7jgjb1qpwiyjj1gnfp4rjmzpc"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("boost" ,boost)
+       ("kactivities" ,kactivities)
+       ("kconfig" ,kconfig)
+       ("qtbase" ,qtbase)
+       ("qtdeclarative" ,qtdeclarative)))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "Access usage statistics collected by the activity manager")
+    (description "The KActivitiesStats library provides a querying mechanism for
+the data that the activitiy manager collects - which documents have been opened
+by which applications, and what documents have been linked to which activity.")
+    ;; triple licensed
+    (license (list license:lgpl2.0+ license:lgpl2.1+ license:lgpl3+))))