summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-02-24 11:14:09 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-06 23:28:29 +0000
commitfbc7a0efa7136d14265533932a19eb501214e7f9 (patch)
tree1eba53484631fee2e16243bb599ae45d9ac290c0 /gnu
parent9af99245e78f96cd494203e3f48edeb420db173d (diff)
downloadguix-fbc7a0efa7136d14265533932a19eb501214e7f9.tar.gz
gnu: Add go-github-com-dave-jennifer.
* gnu/packages/golang-xyz.scm (go-github-com-dave-jennifer): New variable.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 8d77ee956a..6cbdaeee13 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -562,6 +562,29 @@ of unit files.")))
 metrics to Graphite.")
     (license license:bsd-2)))
 
+(define-public go-github-com-dave-jennifer
+  (package
+    (name "go-github-com-dave-jennifer")
+    (version "1.7.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/dave/jennifer")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "01sgafbds8n5zs61qf057whn06yj6avz30xgxk6pllf22528558m"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:go go-1.20
+      #:import-path "github.com/dave/jennifer"))
+    (home-page "https://github.com/dave/jennifer")
+    (synopsis "Code generator for Go")
+    (description "This package provides functionality to generate Go code.")
+    (license license:expat)))
+
 (define-public go-github-com-dimchansky-utfbom
   (package
     (name "go-github-com-dimchansky-utfbom")