summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-10-10 12:11:30 +0200
committerJanneke Nieuwenhuizen <janneke@gnu.org>2023-10-10 18:45:44 +0200
commitfc6c910f797ea232f6019c4ca5dbd105f78928df (patch)
tree330b865768fc1cc19dde6b44ae608a215b46b241 /gnu
parentf4e8baf3806e79d7111d2943859865ae4ee0b59d (diff)
downloadguix-fc6c910f797ea232f6019c4ca5dbd105f78928df.tar.gz
gnu: curl/fixed: Skip failing test on the Hurd.
* gnu/packages/curl.scm (curl/fixed)[arguments]: When building on the Hurd,
replace `check' phase to skip test 1474.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/curl.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index cadf1ca361..e3d17f97b7 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -167,7 +167,26 @@ tunneling, and so on.")
                 (sha256
                  (base32
                   "0qza6yf20y2l4aaxkn8dfw8p3fls1mxljvdb0m8z1i6ncxvn4v9p"))
-                (patches (search-patches "curl-use-ssl-cert-env.patch")))))))
+                (patches (search-patches "curl-use-ssl-cert-env.patch"))))
+      (arguments
+       (if (system-hurd?)
+           (substitute-keyword-arguments (package-arguments curl)
+             ((#:phases phases '%standard-phases)
+              #~(modify-phases #$phases
+                  ;; We cannot simply set #:make-flags because they are
+                  ;; ignored by curl's custom check phase.
+                  (replace 'check
+                    (lambda* (#:key tests? make-flags #:allow-other-keys)
+                      (substitute* "tests/runtests.pl"
+                        (("/bin/sh") (which "sh")))
+                      ;; See comment in curl about check/test.
+                      (let ((arguments `("-C" "tests" "test"
+                                         ,@make-flags
+                                         ;; protocol FAIL
+                                         "TFLAGS=~1474")))
+                        (when tests?
+                          (apply invoke "make" arguments))))))))
+           (package-arguments curl))))))
 
 (define-public curl-ssh
   (package/inherit curl