summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2022-03-26 09:22:09 +0800
committer宋文武 <iyzsong@member.fsf.org>2022-03-26 11:39:00 +0800
commitfc9ac2ac64a39f7bb8433428982da62c170d14e9 (patch)
tree1dbe1c7f0a5d21badb71b138eeaf05442e3c3e8c /gnu
parent2e55a4c6b9153fd1db60122cb29cee466693a753 (diff)
downloadguix-fc9ac2ac64a39f7bb8433428982da62c170d14e9.tar.gz
gnu: Add xfdashboard.
* gnu/packages/xfce.scm (xfdashboard): New variable.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xfce.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index a2d8e99290..bc19fc5250 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -932,6 +932,47 @@ menubar and the window decorations are hidden) that helps you to save space
 on your desktop.")
     (license gpl2+)))
 
+(define-public xfdashboard
+  (package
+    (name "xfdashboard")
+    (version "0.8.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://archive.xfce.org/src/apps/"
+                                  name
+                                  "/"
+                                  (version-major+minor version)
+                                  "/"
+                                  name
+                                  "-"
+                                  version
+                                  ".tar.bz2"))
+              (sha256
+               (base32
+                "1xfyli91gpw7bn9gjk6gp8lnn50qsjd5lh5mzypz9kx3l88wbas4"))))
+    (build-system gnu-build-system)
+    (native-inputs (list intltool pkg-config `(,glib "bin")))
+    (inputs (list clutter
+                  garcon
+                  gtk+
+                  libwnck
+                  libxcomposite
+                  libxdamage
+                  libxfce4util
+                  libxfce4ui
+                  libxinerama
+                  xfconf))
+    (home-page "https://www.xfce.org/")
+    (synopsis "Gnome shell like dashboard for Xfce")
+    (description
+     "Xfdashboard provides a GNOME shell dashboard and MacOS Mission Control
+like interface for Xfce desktop.  It can be configured to run with any
+keyboard shortcut, when executed it provides an overview of applications
+currently opened which let user to switch between different applications.  Its
+search feature works like Xfce's app finder and makes it convenient to search
+for and start applications.")
+    (license gpl2+)))
+
 (define-public mate-polkit-for-xfce
   (package/inherit mate-polkit
     (arguments