summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-01-29 11:02:47 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-01-29 11:03:40 +0100
commitfe058ffb53590d69d0a054773e3bd116c8dfe846 (patch)
treef78bda4210727ce0790e2024b3960614395e2baa /gnu
parentc21ad767d4368dbd9ff37a6fd5cdea8aa37fec57 (diff)
downloadguix-fe058ffb53590d69d0a054773e3bd116c8dfe846.tar.gz
gnu: Add swarp.
* gnu/packages/astronomy.scm (swarp): New variable.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index c22bfb8709..cec37113bf 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -327,6 +327,25 @@ produce realistic astronomical fields.  Stuff is part of the EFIGI development
 project.")
     (license license:gpl3+)))
 
+(define-public swarp
+  (package
+    (name "swarp")
+    (version "2.38.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://www.astromatic.net/download/swarp/"
+                           "swarp-" version ".tar.gz"))
+       (sha256
+        (base32 "1i670waqp54vin1cn08mqckcggm9zqd69nk7yya2vvqpdizn6jpm"))))
+    (build-system gnu-build-system)
+    (home-page "https://www.astromatic.net/software/swarp")
+    (synopsis "FITS image resampling and co-addition")
+    (description
+     "SWarp is a program that resamples and co-adds together FITS images using
+any arbitrary astrometric projection defined in the WCS standard.")
+    (license license:gpl3+)))
+
 (define-public celestia
   (let ((commit "9dbdf29c4ac3d20afb2d9a80d3dff241ecf81dce"))
     (package