summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-02-10 15:48:21 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-02-10 19:36:36 +0100
commitfea66096a291f5eaf762da430e339feacac391b4 (patch)
tree40f77c3c19f786b2c0076186acab6d9820aa80d8 /gnu
parentcf981657a1d4c6ba64bf7e9a015d2be239ca85c2 (diff)
downloadguix-fea66096a291f5eaf762da430e339feacac391b4.tar.gz
gnu: Add python-doubletdetection.
* gnu/packages/bioinformatics.scm (python-doubletdetection): New variable.

Co-authored-by: Navid Afkhami <navid.afkhami@mdc-berlin.de>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c70dcdf93b..ad8754f106 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1178,6 +1178,54 @@ It is the demultiplexing module of Pegasus, which is used by Cumulus in the
 demultiplexing step.")
     (license license:bsd-3)))
 
+(define-public python-doubletdetection
+  (package
+    (name "python-doubletdetection")
+    (version "4.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "doubletdetection" version))
+              (sha256
+               (base32
+                "0v0a19014h4p6x8pyz1s78xn3q5w5166cysvg574z6vw79a3s9vp"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:tests? #false ;there are none
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'use-poetry-core
+            (lambda _
+              ;; Patch to use the core poetry API.
+              (substitute* "pyproject.toml"
+                (("poetry.masonry.api")
+                 "poetry.core.masonry.api")))))))
+    (propagated-inputs
+     (list python-anndata
+           python-ipywidgets
+           python-leidenalg
+           python-vtraag-louvain
+           python-matplotlib
+           python-numpy
+           python-pandas
+           python-phenograph
+           python-scanpy
+           python-scipy
+           python-tqdm))
+    (native-inputs
+     (list python-black
+           python-flake8
+           python-poetry-core
+           python-pytest
+           python-pre-commit))
+    (home-page "https://github.com/JonathanShor/DoubletDetection")
+    (synopsis
+     "This is a package to detect doublets in single-cell RNA-seq count matrices")
+    (description
+     "This package provides a method to detect and enable removal of doublets
+from single-cell RNA-sequencing.")
+    (license license:expat)))
+
 (define-public python-hclust2
   (package
     (name "python-hclust2")