summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-06-16 22:25:55 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-06-17 06:52:18 +0300
commitfeabb770e168d026a672a1bf9df2435efdae9288 (patch)
tree04ea78758b292ae0870703bd8e94778a6c51e708 /gnu
parent2e6973222d03200adb4c56adfd953aa46bba6e4c (diff)
downloadguix-feabb770e168d026a672a1bf9df2435efdae9288.tar.gz
gnu: python-efl: Rebuild generated C files.
* gnu/packages/enlightenment.scm (python-efl)[arguments]: Replace 'build
phase to set 'ENABLE_CYTHON=1'.
[native-inputs]: python-cython.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/enlightenment.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index c487fc1020..ee017277ee 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -324,13 +324,18 @@ embedded systems.")
     (arguments
      '(#:phases
        (modify-phases %standard-phases
+        (replace 'build
+          (lambda _
+            (zero?
+              (system* "env" "ENABLE_CYTHON=1" "python" "setup.py" "build"))))
         (add-before 'build 'set-flags
          (lambda _
            (setenv "CFLAGS"
                    (string-append "-I" (assoc-ref %build-inputs "python-dbus")
                                   "/include/dbus-1.0")))))))
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     `(("pkg-config" ,pkg-config)
+       ("python-cython" ,python-cython)))
     (inputs
      `(("efl" ,efl)
        ("elementary" ,elementary)