summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-08-01 13:54:06 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-08-02 15:20:43 +0200
commitfede3a903eb1edc97c296c83f3d1d28f98ded3f8 (patch)
treec37084b64e1f5852271f1c45646517c80a0a12bd /gnu
parent3701f014b1f2041a8e117b49c204e918adad2eca (diff)
downloadguix-fede3a903eb1edc97c296c83f3d1d28f98ded3f8.tar.gz
gnu: Add emacs-visual-fill-column.
* gnu/packages/emacs.scm (emacs-visual-fill-column): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 97c21f1bc0..825a355d63 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -2697,6 +2697,30 @@ identifiers based on their names.  Each identifier gets a color based on a hash
 of its name.")
     (license license:bsd-2)))
 
+(define-public emacs-visual-fill-column
+  (package
+    (name "emacs-visual-fill-column")
+    (version "1.7")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://codeload.github.com/joostkremers/"
+                                  "visual-fill-column/tar.gz/" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "12vn7kdq2mpz9hgibbn1vhpf23lcm7c26k3fkz8nidhygwl5x5lq"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/joostkremers/visual-fill-column")
+    (synopsis "Fill-column for visual-line-mode")
+    (description
+     "@code{visual-fill-column-mode} is a small Emacs minor mode that mimics
+the effect of @code{fill-column} in @code{visual-line-mode}.  Instead of
+wrapping lines at the window edge, which is the standard behaviour of
+@code{visual-line-mode}, it wraps lines at @code{fill-column}.  If
+@code{fill-column} is too large for the window, the text is wrapped at the
+window edge.")
+    (license license:gpl3+)))
+
 (define-public emacs-ido-completing-read+
   (package
     (name "emacs-ido-completing-read+")