summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-15 23:11:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-16 10:48:00 +0200
commitff0d34a29bc0f19b1dd2714fc0a3bd73a244aebe (patch)
tree42e976ea394329f75ff6c5bcb1968bfcd01dc3ab /gnu
parent093e9204183790558921c968034c547b41ebef3a (diff)
downloadguix-ff0d34a29bc0f19b1dd2714fc0a3bd73a244aebe.tar.gz
gnu: r-with-tests: Fix reference to grep.
detectCores.R fails to return the number of cores when running R in a
container without grep.

Reported-by: Jonas Freimuth.

* gnu/packages/statistics.scm (r-with-tests)[arguments]: Fix references to
grep and wc in detectCores.R.
[inputs]: Add grep.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index f28e60362c..2043bf2fd3 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -244,7 +244,15 @@ This package also provides @command{xls2csv} to export Excel files to CSV.")
                (substitute* "src/scripts/R.sh.in"
                  (("uname") uname-bin))
                (substitute* "src/unix/sys-std.c"
-                 (("rm -Rf ") (string-append rm-bin " -Rf "))))))
+                 (("rm -Rf ") (string-append rm-bin " -Rf ")))
+               (substitute* "src/library/parallel/R/detectCores.R"
+                 (("'grep")
+                  (string-append "'"
+                                 (search-input-file inputs "/bin/grep")))
+                 (("\\| wc -l")
+                  (string-append "| "
+                                 (search-input-file inputs "/bin/wc")
+                                 " -l"))))))
          (add-after 'unpack 'patch-tests
            (lambda _
              ;; This is needed because R is run during the check phase and
@@ -401,6 +409,7 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
            curl
            openblas
            gfortran
+           grep
            icu4c
            libjpeg-turbo
            libpng