summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-10-15 10:39:56 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-10-15 10:39:56 +0200
commitff3fca30803cfc4d92342e62ab08c39e4f436c0e (patch)
tree01543d949ebe502e084735ffca2d248a833f7a88 /gnu
parent26127c9a5815c26da5829e30c236c6b93edc564d (diff)
downloadguix-ff3fca30803cfc4d92342e62ab08c39e4f436c0e.tar.gz
gnu: Add emacs-yaml.
* gnu/packages/emacs-xyz.scm (emacs-yaml): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 375e0cac92..8233089886 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10866,6 +10866,28 @@ Emacs completion function instead.")
 that uses the standard completion function completing-read.")
   (license license:gpl3+)))
 
+(define-public emacs-yaml
+  (package
+    (name "emacs-yaml")
+    (version "0.3.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/zkry/yaml.el")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "13fjxrr7iyfagbm21p5is5jw1zv56ns2mnac145v8lqli6mrr5gx"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/zkry/yaml.el")
+    (synopsis "YAML parser in Elisp")
+    (description
+     "@code{yaml.el} is a YAML parser written in Emacs List without
+any external dependencies.  It provides an interface similar to the
+Emacs JSON parsing utility.")
+    (license license:gpl3+)))
+
 (define-public emacs-yaml-mode
   (package
     (name "emacs-yaml-mode")