summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-10 09:27:03 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:45 +0200
commitff5a1ab05d104629eb3f88fb380afd82f751d134 (patch)
treecea33801649205c8219f3b1de8d5751f390ace7f /gnu
parent90faae4c1216d1c2505cea12c1dfc9b2e0cd0b64 (diff)
downloadguix-ff5a1ab05d104629eb3f88fb380afd82f751d134.tar.gz
gnu: Add texlive-collection-langfrench.
* gnu/packages/tex.scm (texlive-collection-langfrench): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a1ab18a605..bc5d6725cb 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -32944,6 +32944,62 @@ others (Greek, German, French, ...)  have their own collections, depending
 simply on the size of the support.")
     (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
 
+(define-public texlive-collection-langfrench
+  (package
+    (name "texlive-collection-langfrench")
+    (version (number->string %texlive-revision))
+    (source #f)
+    (build-system trivial-build-system)
+    (arguments (list #:builder #~(mkdir #$output)))
+    (propagated-inputs
+     (list texlive-aeguill
+           texlive-annee-scolaire
+           texlive-apprendre-a-programmer-en-tex
+           texlive-apprends-latex
+           texlive-babel-basque
+           texlive-babel-french
+           texlive-basque-book
+           texlive-basque-date
+           texlive-bib-fr
+           texlive-bibleref-french
+           texlive-booktabs-fr
+           texlive-collection-basic
+           texlive-droit-fr
+           texlive-e-french
+           texlive-epslatex-fr
+           texlive-expose-expl3-dunkerque-2019
+           texlive-facture
+           texlive-formation-latex-ul
+           texlive-frenchmath
+           texlive-frletter
+           texlive-frpseudocode
+           texlive-hyphen-complete
+           texlive-impatient-fr
+           texlive-impnattypo
+           texlive-l2tabu-french
+           texlive-latex2e-help-texinfo-fr
+           texlive-letgut
+           texlive-lshort-french
+           texlive-mafr
+           texlive-matapli
+           texlive-profcollege
+           texlive-proflabo
+           texlive-proflycee
+           texlive-tabvar
+           texlive-tdsfrmath
+           texlive-translation-array-fr
+           texlive-translation-dcolumn-fr
+           texlive-translation-natbib-fr
+           texlive-translation-tabbing-fr
+           texlive-variations
+           texlive-visualfaq-fr
+           texlive-visualtikz))
+    (home-page "https://www.tug.org/texlive/")
+    (synopsis "Support for French and Basque")
+    (description
+     "This collection provides support packages for French and Basque.")
+    (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
 (define-public texlive-collection-latex
   (package
     (name "texlive-collection-latex")