summary refs log tree commit diff
path: root/guix/build-system
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-04-21 16:18:52 -0400
committerLeo Famulari <leo@famulari.name>2023-04-30 04:47:18 -0400
commit3b5b6683037dfb8f02d04ad3e6c2f04062db9a16 (patch)
treecb8b6b4e8bcf2a5176c23ef397b6a6ab7194328f /guix/build-system
parentd3e91a83b6380e313579f4d72db9b9e2162062ec (diff)
downloadguix-3b5b6683037dfb8f02d04ad3e6c2f04062db9a16.tar.gz
build-system/cmake: Add support for the #:disallowed-references key.
* guix/build-system/cmake.scm (cmake-build, cmake-cross-build):
Add #:disallowed-references.
Diffstat (limited to 'guix/build-system')
-rw-r--r--guix/build-system/cmake.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/guix/build-system/cmake.scm b/guix/build-system/cmake.scm
index 323e4aed16..aa187c9844 100644
--- a/guix/build-system/cmake.scm
+++ b/guix/build-system/cmake.scm
@@ -115,7 +115,8 @@
                       (substitutable? #t)
                       (imported-modules %cmake-build-system-modules)
                       (modules '((guix build cmake-build-system)
-                                 (guix build utils))))
+                                 (guix build utils)))
+                      disallowed-references)
   "Build SOURCE using CMAKE, and with INPUTS. This assumes that SOURCE
 provides a 'CMakeLists.txt' file as its build system."
   (define build
@@ -157,6 +158,7 @@ provides a 'CMakeLists.txt' file as its build system."
                       #:target #f
                       #:graft? #f
                       #:substitutable? substitutable?
+                      #:disallowed-references disallowed-references
                       #:guile-for-build guile)))
 
 
@@ -190,7 +192,8 @@ provides a 'CMakeLists.txt' file as its build system."
                             (build (nix-system->gnu-triplet system))
                             (imported-modules %cmake-build-system-modules)
                             (modules '((guix build cmake-build-system)
-                                       (guix build utils))))
+                                       (guix build utils)))
+                            disallowed-references)
   "Cross-build NAME using CMAKE for TARGET, where TARGET is a GNU triplet and
 with INPUTS.  This assumes that SOURCE provides a 'CMakeLists.txt' file as its
 build system."