summary refs log tree commit diff
path: root/guix/build-system
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-10-27 20:31:38 +0200
committerMarius Bakke <marius@gnu.org>2022-10-27 21:30:03 +0200
commite944734ef9afa1ac9b46579934482b7d909ed24e (patch)
tree3264c818aa7f37fb5ca3b9cd1b12687f464ffc6f /guix/build-system
parent6ef998d54e57c8969bc3db7888fb7d4939a6fa83 (diff)
downloadguix-e944734ef9afa1ac9b46579934482b7d909ed24e.tar.gz
build-system/pyproject: Always run tests verbosely for supported backends.
* guix/build-system/pyproject.scm (pyproject-build): Default to '() instead of
 #false for TEST-FLAGS.
* guix/build/pyproject-build-system.scm (check): Unconditionally enable
verbose test flags.
* doc/guix.texi (Build Systems): Document this change.
* gnu/packages/fontutils.scm (python-glyphslib)[arguments]: Remove verbosity
from #:test-flags.
* gnu/packages/pdf.scm (python-pydyf, weasyprint)[arguments]: Likewise.
* gnu/packages/python-web.scm (python-openapi-spec-validator)[arguments]: Likewise.
* gnu/packages/python-xyz.scm (python-path, python-tempora)[arguments]: Likewise.
Diffstat (limited to 'guix/build-system')
-rw-r--r--guix/build-system/pyproject.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/guix/build-system/pyproject.scm b/guix/build-system/pyproject.scm
index 1e365d4f21..8f3b562ca3 100644
--- a/guix/build-system/pyproject.scm
+++ b/guix/build-system/pyproject.scm
@@ -95,7 +95,7 @@
                           (configure-flags ''())
                           (build-backend #f)
                           (test-backend #f)
-                          (test-flags #f)
+                          (test-flags ''())
                           (phases '%standard-phases)
                           (outputs '("out" "wheel"))
                           (search-paths '())