summary refs log tree commit diff
path: root/guix/cve.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-09-07 23:12:27 +0200
committerLudovic Courtès <ludo@gnu.org>2020-09-08 00:47:35 +0200
commitb5eb901ab508e13a10d8c11fe0c9d0d06dddce96 (patch)
treee8555d5c52e27edf3dfa097c402964ccb24ffd0d /guix/cve.scm
parentd15c7974a2346ec0d379eba3fd60ef59012d9a80 (diff)
downloadguix-b5eb901ab508e13a10d8c11fe0c9d0d06dddce96.tar.gz
Remove (guix json) and require Guile-JSON 4.3.0+.
This is a followup to 4071879c86d059ee087c8986915ea72b8c742b72.

* guix/json.scm: Remove.
* Makefile.am (MODULES): Adjust accordingly.
* m4/guix.m4 (GUIX_CHECK_GUILE_JSON): Check for 'define-json-mapping'.
* doc/guix.texi (Requirements): Require Guile-JSON 4.3.0+.
* guix/ci.scm, guix/cve.scm, guix/import/cpan.scm,
guix/import/crate.scm, guix/swh.scm: Remove (guix json) import.
* guix/import/gem.scm, guix/import/pypi.scm: Likewise, and import (json).
* guix/self.scm (specification->package): Switch to GUILE-JSON-4.
* guix/git-download.scm (git-fetch): Likewise.
Diffstat (limited to 'guix/cve.scm')
-rw-r--r--guix/cve.scm1
1 files changed, 0 insertions, 1 deletions
diff --git a/guix/cve.scm b/guix/cve.scm
index ae9cca2341..57b8459d01 100644
--- a/guix/cve.scm
+++ b/guix/cve.scm
@@ -19,7 +19,6 @@
 (define-module (guix cve)
   #:use-module (guix utils)
   #:use-module (guix http-client)
-  #:use-module (guix json)
   #:use-module (guix i18n)
   #:use-module ((guix diagnostics) #:select (formatted-message))
   #:use-module (json)