summary refs log tree commit diff
path: root/guix/hg-download.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-06-15 10:38:10 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-06-15 17:02:18 +0200
commitc4e48b68bdf41e7f6805473fc4f545b215251c6d (patch)
tree9770d6e6dc0e6f1c9a7ef172a74dc6cb7ddc529c /guix/hg-download.scm
parent9c4a8514d621b6e2a19f56fa9b3396c940b968c5 (diff)
downloadguix-c4e48b68bdf41e7f6805473fc4f545b215251c6d.tar.gz
guix: Add downloader for Mercurial repositories.
* guix/build/hg.scm: New file.
* guix/hg-download.scm: New file.
* Makefile.am (MODULES): Add them.
Diffstat (limited to 'guix/hg-download.scm')
-rw-r--r--guix/hg-download.scm84
1 files changed, 84 insertions, 0 deletions
diff --git a/guix/hg-download.scm b/guix/hg-download.scm
new file mode 100644
index 0000000000..f3e1d2906a
--- /dev/null
+++ b/guix/hg-download.scm
@@ -0,0 +1,84 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix hg-download)
+  #:use-module (guix gexp)
+  #:use-module (guix store)
+  #:use-module (guix monads)
+  #:use-module (guix records)
+  #:use-module (guix packages)
+  #:autoload   (guix build-system gnu) (standard-packages)
+  #:use-module (ice-9 match)
+  #:export (hg-reference
+            hg-reference?
+            hg-reference-url
+            hg-reference-changeset
+            hg-reference-recursive?
+
+            hg-fetch))
+
+;;; Commentary:
+;;;
+;;; An <origin> method that fetches a specific changeset from a Mercurial
+;;; repository.  The repository URL and changeset ID are specified with a
+;;; <hg-reference> object.
+;;;
+;;; Code:
+
+(define-record-type* <hg-reference>
+  hg-reference make-hg-reference
+  hg-reference?
+  (url        hg-reference-url)
+  (changeset  hg-reference-changeset))
+
+(define (hg-package)
+  "Return the default Mercurial package."
+  (let ((distro (resolve-interface '(gnu packages version-control))))
+    (module-ref distro 'mercurial)))
+
+(define* (hg-fetch ref hash-algo hash
+                   #:optional name
+                   #:key (system (%current-system)) (guile (default-guile))
+                   (hg (hg-package)))
+  "Return a fixed-output derivation that fetches REF, a <hg-reference>
+object.  The output is expected to have recursive hash HASH of type
+HASH-ALGO (a symbol).  Use NAME as the file name, or a generic name if #f."
+  (define build
+    #~(begin
+        (use-modules (guix build hg)
+                     (guix build utils)
+                     (ice-9 match))
+
+        (hg-fetch '#$(hg-reference-url ref)
+                  '#$(hg-reference-changeset ref)
+                  #$output
+                  #:hg-command (string-append #+hg "/bin/hg"))))
+
+  (mlet %store-monad ((guile (package->derivation guile system)))
+    (gexp->derivation (or name "hg-checkout") build
+                      #:system system
+                      #:local-build? #t           ;don't offload repo cloning
+                      #:hash-algo hash-algo
+                      #:hash hash
+                      #:recursive? #t
+                      #:modules '((guix build hg)
+                                  (guix build utils))
+                      #:guile-for-build guile)))
+
+;;; hg-download.scm ends here