summary refs log tree commit diff
path: root/guix/swh.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-09-01 13:24:03 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-04 13:02:27 +0200
commit76073d29e11c71d3678efd44db646852b5502e55 (patch)
tree80a271a5d82bf9eb13cb4891638218f0ac5657c1 /guix/swh.scm
parent91300526b7d9d775bd98a700ed3758420ef9eac6 (diff)
downloadguix-76073d29e11c71d3678efd44db646852b5502e55.tar.gz
Add (guix json).
* guix/swh.scm (define-json-reader, define-json-mapping): Move to...
* guix/json.scm: ... here.  New file.
* Makefile.am (MODULES): Add it.
Diffstat (limited to 'guix/swh.scm')
-rw-r--r--guix/swh.scm35
1 files changed, 1 insertions, 34 deletions
diff --git a/guix/swh.scm b/guix/swh.scm
index 01648a1ebe..7acad05928 100644
--- a/guix/swh.scm
+++ b/guix/swh.scm
@@ -21,6 +21,7 @@
   #:use-module (guix build utils)
   #:use-module ((guix build syscalls) #:select (mkdtemp!))
   #:use-module (web uri)
+  #:use-module (guix json)
   #:use-module (web client)
   #:use-module (web response)
   #:use-module (json)
@@ -135,40 +136,6 @@
       url
       (string-append url "/")))
 
-(define-syntax-rule (define-json-reader json->record ctor spec ...)
-  "Define JSON->RECORD as a procedure that converts a JSON representation,
-read from a port, string, or hash table, into a record created by CTOR and
-following SPEC, a series of field specifications."
-  (define (json->record input)
-    (let ((table (cond ((port? input)
-                        (json->scm input))
-                       ((string? input)
-                        (json-string->scm input))
-                       ((or (null? input) (pair? input))
-                        input))))
-      (let-syntax ((extract-field (syntax-rules ()
-                                    ((_ table (field key json->value))
-                                     (json->value (assoc-ref table key)))
-                                    ((_ table (field key))
-                                     (assoc-ref table key))
-                                    ((_ table (field))
-                                     (assoc-ref table
-                                                (symbol->string 'field))))))
-        (ctor (extract-field table spec) ...)))))
-
-(define-syntax-rule (define-json-mapping rtd ctor pred json->record
-                      (field getter spec ...) ...)
-  "Define RTD as a record type with the given FIELDs and GETTERs, à la SRFI-9,
-and define JSON->RECORD as a conversion from JSON to a record of this type."
-  (begin
-    (define-record-type rtd
-      (ctor field ...)
-      pred
-      (field getter) ...)
-
-    (define-json-reader json->record ctor
-      (field spec ...) ...)))
-
 (define %date-regexp
   ;; Match strings like "2014-11-17T22:09:38+01:00" or
   ;; "2018-09-30T23:20:07.815449+00:00"".