summary refs log tree commit diff
path: root/m4
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-02-15 16:13:36 +0100
committerLudovic Courtès <ludo@gnu.org>2018-02-26 18:19:34 +0100
commit1d84d7bf6052c0c80bd212d4524876576e9817d4 (patch)
tree469a7694b9ebacf8949758d79febebc7c399233d /m4
parentcb723be5b98a57ae4f909022d1ce2b5d3bcdaabf (diff)
downloadguix-1d84d7bf6052c0c80bd212d4524876576e9817d4.tar.gz
build: Require Guile >= 2.0.13.
* README, configure.ac, doc/guix.texi (Requirements): Increase minimum
Guile version from 2.0.9 to 2.0.13.
* config-daemon.ac: Remove use of 'GUIX_CHECK_UNBUFFERED_CBIP'.
* m4/guix.m4 (GUIX_CHECK_UNBUFFERED_CBIP): Remove.
* guix/build/download.scm (current-http-proxy): Remove.
* guix/build/syscalls.scm (%libc-errno-pointer, errno): Remove.
(syscall->procedure): Use #:return-errno unconditionally.
* guix/hash.scm (open-sha256-input-port)[unbuffered]: Remove outdated
comment.
* guix/http-client.scm (when-guile<=2.0.5-or-otherwise-broken): Remove.
<top level>: Remove 'when-guile<=2.0.5-or-otherwise-broken' block.
* guix/scripts/substitute.scm (fetch): Remove 'guile-version>?'
conditional.
* tests/hash.scm (supports-unbuffered-cbip?): Remove.
<top level>: Remove 'test-skip' call.
Diffstat (limited to 'm4')
-rw-r--r--m4/guix.m417
1 files changed, 0 insertions, 17 deletions
diff --git a/m4/guix.m4 b/m4/guix.m4
index 721285b014..8e174e92e5 100644
--- a/m4/guix.m4
+++ b/m4/guix.m4
@@ -136,23 +136,6 @@ AC_DEFUN([GUIX_ASSERT_GUILE_FEATURES], [
   done
 ])
 
-dnl GUIX_CHECK_UNBUFFERED_CBIP
-dnl
-dnl Check whether 'setbvuf' works on custom binary input ports (CBIPs), as is
-dnl the case starting with Guile 2.0.10.
-AC_DEFUN([GUIX_CHECK_UNBUFFERED_CBIP], [
-  AC_CACHE_CHECK([whether Guile's custom binary input ports support 'setvbuf'],
-    [ac_cv_guix_cbips_support_setvbuf],
-    [if "$GUILE" -c "(use-modules (rnrs io ports))			\
-       (let ((p (make-custom-binary-input-port \"cbip\" pk #f #f #f)))	\
-         (setvbuf p _IONBF))" >&5 2>&1
-     then
-       ac_cv_guix_cbips_support_setvbuf=yes
-     else
-       ac_cv_guix_cbips_support_setvbuf=no
-     fi])
-])
-
 dnl GUIX_ASSERT_SYNTAX_OBJECT_EQUAL
 dnl
 dnl Guile 2.2.1 was a brown-paper-bag release where 'equal?' wouldn't work