summary refs log tree commit diff
path: root/m4
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-09 20:53:55 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-09 20:57:24 +0200
commitca34fc317f7a812285805f0cc6b41ccae6d57434 (patch)
tree46c484f904014f20acef0687d26420abb0e67181 /m4
parent1de2fe95e017c42aacbaa34f5dab8d48249cc064 (diff)
downloadguix-ca34fc317f7a812285805f0cc6b41ccae6d57434.tar.gz
build: Fix libgcrypt detection on FHS systems.
Reported by Christopher Allan Webber <cwebber@dustycloud.org>.

* m4/guix.m4 (GUIX_LIBGCRYPT_LIBDIR): Add "grep -e -L" to the pipeline
  to account for cases where the output of "libgcrypt-config --libs"
  lacks a -L flag.
* configure.ac: When 'GUIX_LIBGCRYPT_LIBDIR' returns the empty string,
  set LIBGCRYPT_LIBDIR to "no".
* config-daemon.ac: Add missing space.
Diffstat (limited to 'm4')
-rw-r--r--m4/guix.m42
1 files changed, 1 insertions, 1 deletions
diff --git a/m4/guix.m4 b/m4/guix.m4
index d464a478ca..842249a848 100644
--- a/m4/guix.m4
+++ b/m4/guix.m4
@@ -279,7 +279,7 @@ AC_DEFUN([GUIX_LIBGCRYPT_LIBDIR], [
   AC_CACHE_CHECK([libgcrypt's library directory],
     [guix_cv_libgcrypt_libdir],
     [if test "x$LIBGCRYPT_CONFIG" != "x"; then
-       guix_cv_libgcrypt_libdir=`$LIBGCRYPT_CONFIG --libs | sed -e "s/.*-L\([[^ ]]\+\)[[[:blank:]]]\+-lgcrypt.*/\1/g"`
+       guix_cv_libgcrypt_libdir=`$LIBGCRYPT_CONFIG --libs | grep -e -L | sed -e "s/.*-L\([[^ ]]\+\)[[[:blank:]]]\+-lgcrypt.*/\1/g"`
      else
        guix_cv_libgcrypt_libdir=""
      fi])