summary refs log tree commit diff
path: root/m4
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-05 23:02:47 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-06 00:07:17 +0100
commitd8eea3d2bce9c9e834210237090947de4600cfe8 (patch)
tree5572df7de406f06b31f6be7d68526f69208442b1 /m4
parent69cfce50dbb2000c5f5d98f0f364fe324004bf99 (diff)
downloadguix-d8eea3d2bce9c9e834210237090947de4600cfe8.tar.gz
build: Capture configure-time settings in (guix config).
* configure.ac: Compute and substitute `guix_localstatedir'.
* m4/guix.m4: Substitute `guix_system'.
* guix/config.scm.in (%store-directory, %store-directory, %system): New
  variables.
* guix/store.scm (%nix-state-dir): Remove.
  (%default-socket-path): Use %STATE-DIRECTORY as the default.
  (%store-prefix): Use %STORE-DIRECTORY as the default.
* guix/utils.scm (%current-system): Default to %SYSTEM.
Diffstat (limited to 'm4')
-rw-r--r--m4/guix.m41
1 files changed, 1 insertions, 0 deletions
diff --git a/m4/guix.m4 b/m4/guix.m4
index 9b5184ff55..7d7d7381a0 100644
--- a/m4/guix.m4
+++ b/m4/guix.m4
@@ -61,4 +61,5 @@ AC_DEFUN([GUIX_SYSTEM_TYPE], [
 	  # `darwin10.2.0', etc.
 	  guix_system="$machine_name-`echo $host_os | "$SED" -e's/@<:@0-9.@:>@*$//g'`";;
      esac])
+  AC_SUBST([guix_system])
 ])