summary refs log tree commit diff
path: root/tests/monads.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-10-05 16:25:25 +0200
committerLudovic Courtès <ludo@gnu.org>2014-10-05 21:58:42 +0200
commitb4469d8c12905f07a6825654bc3313beb0563cad (patch)
treed227b0066bbccd325c6eeac6a8b287cb06bae403 /tests/monads.scm
parentcdb4b4b3edfe17239e059208b3d86eb61df550be (diff)
downloadguix-b4469d8c12905f07a6825654bc3313beb0563cad.tar.gz
gnu: cross-base: Use the right dynamic linker name.
* gnu/packages/cross-base.scm (cross-gcc-arguments): Parametrize
  %CURRENT-TARGET-SYSTEM.
* tests/monads.scm ("package-file + package->cross-derivation"): Replace
  "foo64-gnu" with "mips64el-linux-gnu".
Diffstat (limited to 'tests/monads.scm')
-rw-r--r--tests/monads.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/monads.scm b/tests/monads.scm
index b31cabdb54..5514c8386c 100644
--- a/tests/monads.scm
+++ b/tests/monads.scm
@@ -123,10 +123,10 @@
 
 (test-assert "package-file + package->cross-derivation"
   (run-with-store %store
-    (mlet* %store-monad ((file (package-file coreutils "bin/ls"
-                                             #:target "foo64-gnu"))
-                         (xcu  (package->cross-derivation coreutils
-                                                          "foo64-gnu")))
+    (mlet* %store-monad ((target -> "mips64el-linux-gnu")
+                         (file (package-file coreutils "bin/ls"
+                                             #:target target))
+                         (xcu  (package->cross-derivation coreutils target)))
       (let ((output (derivation->output-path xcu)))
         (return (string=? file (string-append output "/bin/ls")))))
     #:guile-for-build (package-derivation %store %bootstrap-guile)))