summary refs log tree commit diff
path: root/tests/print.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-27 17:21:39 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-09-28 13:10:10 +0200
commit68a91a183b29c62232fb048bb27e10b6ff2e39dd (patch)
treecea51c097a48806f16259449e4b5079033f2e121 /tests/print.scm
parent523ecbbbedfed6bd902309286e00a6f04b1ff195 (diff)
downloadguix-68a91a183b29c62232fb048bb27e10b6ff2e39dd.tar.gz
import: Add package->code.
* guix/import/print.scm: New file.
* tests/print.scm: New file.
* Makefile.am (SCM_TESTS): Add new test file.
(MODULES): Add print.scm.
Diffstat (limited to 'tests/print.scm')
-rw-r--r--tests/print.scm64
1 files changed, 64 insertions, 0 deletions
diff --git a/tests/print.scm b/tests/print.scm
new file mode 100644
index 0000000000..305807c1d1
--- /dev/null
+++ b/tests/print.scm
@@ -0,0 +1,64 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-print)
+  #:use-module (guix import print)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix download)
+  #:use-module (guix packages)
+  #:use-module (guix licenses)
+  #:use-module (srfi srfi-64))
+
+(test-begin "print")
+
+(define pkg
+  (package
+    (name "test")
+    (version "1.2.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "file:///tmp/test-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "070pwb7brdcn1mfvplkd56vjc7lbz4iznzkqvfsakvgbv68k71ah"))))
+    (build-system gnu-build-system)
+    (home-page "http://gnu.org")
+    (synopsis "Dummy")
+    (description "This is a dummy package.")
+    (license gpl3+)))
+
+(test-equal "simple package"
+  (package->code pkg)
+  '(package
+     (name "test")
+     (version "1.2.3")
+     (source (origin
+               (method url-fetch)
+               (uri (string-append "file:///tmp/test-"
+                                   version ".tar.gz"))
+               (sha256
+                (base32
+                 "070pwb7brdcn1mfvplkd56vjc7lbz4iznzkqvfsakvgbv68k71ah"))))
+     (build-system gnu-build-system)
+     (home-page "http://gnu.org")
+     (synopsis "Dummy")
+     (description "This is a dummy package.")
+     (license gpl3+)))
+
+(test-end "print")