summary refs log tree commit diff
path: root/tests
diff options
context:
space:
mode:
authorFelix Lechner <felix.lechner@lease-up.com>2023-03-20 21:25:41 -0700
committerLudovic Courtès <ludo@gnu.org>2023-03-27 18:48:53 +0200
commitc9af27d4ca733b20f09019f1465d3e5fdc1ec724 (patch)
tree00d781a58b7df2919d857d9f77cce7bd59fe1f74 /tests
parent38e7813c0358a829616c1748c975d1ebf709258d (diff)
downloadguix-c9af27d4ca733b20f09019f1465d3e5fdc1ec724.tar.gz
lint: Append "/info/refs" to git-reference-url.
For the atftp package added in the preceeding commit, lint produced this
warning:

  gnu/packages/networking.scm:2924:5: atftp@0.8.0:
    URI https://git.code.sf.net/p/atftp/code not reachable:
      404 ("Not Found")

Thanks to Sergey Trofimov for suggesting a fix! [1]

  [1]  https://issues.guix.gnu.org/62156#3

It was implemented here, and the warning disappeared.

* guix/lint.scm (check-source): Append "/info/refs" to git-reference-url.

Co-authored-by: Sergey Trofimov <sarg@sarg.org.ru>
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'tests')
-rw-r--r--tests/lint.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/lint.scm b/tests/lint.scm
index ce22e2355a..71e38550a1 100644
--- a/tests/lint.scm
+++ b/tests/lint.scm
@@ -1052,7 +1052,7 @@
     (parameterize ((%http-server-port 0))
       (with-http-server `((,redirect ""))
         (test-equal "source, git-reference: 301 -> 200"
-          (format #f "permanent redirect from ~a to ~a"
+          (format #f "permanent redirect from ~a/info/refs to ~a"
                   (%local-url) initial-url)
           (let ((pkg (dummy-package
                       "x"