summary refs log tree commit diff
path: root/tests
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-04-18 15:37:20 +0200
committerLudovic Courtès <ludo@gnu.org>2021-04-20 12:13:16 +0200
commitd95168321f4a9bf6857b598da0a183b45a868d54 (patch)
tree7b9cc723ce64dc5be805acb4d053757cef707ddb /tests
parentb57f342ac82b8cb3871082f808bf988901bd41fa (diff)
downloadguix-d95168321f4a9bf6857b598da0a183b45a868d54.tar.gz
import: Remove Nix importer.
This importer has suffered from bitrot and no longer works with current
Nix and Nixpkgs.  See <https://bugs.gnu.org/32339> and
<https://bugs.gnu.org/36255>.

* guix/import/snix.scm, guix/scripts/import/nix.scm,
tests/snix.scm: Remove.
* Makefile.am (MODULES, SCM_TESTS): Remove them.
* guix/scripts/import.scm (importers): Remove "nix".
* build-aux/test-env.in: Remove NIXPKGS variable.
* configure.ac: Remove '--with-nixpkgs' option.
* doc/guix.texi (Invoking guix import): Remove bit about "guix import
nix".
* etc/completion/fish/guix.fish: Likewise.
Diffstat (limited to 'tests')
-rw-r--r--tests/snix.scm73
1 files changed, 0 insertions, 73 deletions
diff --git a/tests/snix.scm b/tests/snix.scm
deleted file mode 100644
index 4c31e3389d..0000000000
--- a/tests/snix.scm
+++ /dev/null
@@ -1,73 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (test-snix)
-  #:use-module (guix import snix)
-  #:use-module (srfi srfi-1)
-  #:use-module (srfi srfi-64)
-  #:use-module (ice-9 match))
-
-(define %nixpkgs-directory
-  (getenv "NIXPKGS"))
-
-(define factorize-uri
-  (@@ (guix import snix) factorize-uri))
-
-(define-syntax-rule (every? proc lists ...)
-  (not (not (every proc lists ...))))
-
-(test-begin "snix")
-
-(test-assert "factorize-uri"
-  (every? (match-lambda
-           ((uri version '-> expected)
-            (equal? (factorize-uri uri version)
-                    expected)))
-          '(("http://example.com/foo.tgz" "1.0"
-             -> "http://example.com/foo.tgz")
-            ("http://example.com/foo-2.8.tgz" "2.8"
-             -> ("http://example.com/foo-" version ".tgz"))
-            ("http://example.com/2.8/foo-2.8.tgz" "2.8"
-             -> ("http://example.com/" version "/foo-" version ".tgz")))))
-
-(test-skip (if (and %nixpkgs-directory
-                    (file-exists? (string-append %nixpkgs-directory
-                                                 "/default.nix")))
-               0
-               1))
-
-(test-assert "nixpkgs->guix-package"
-  (match (nixpkgs->guix-package %nixpkgs-directory "guile")
-    (('package
-       ('name "guile")
-       ('version (? string?))
-       ('source ('origin _ ...))
-       ('build-system _)
-       ('inputs ('quasiquote (inputs ...)))
-       ('propagated-inputs ('quasiquote (pinputs ...)))
-       ('home-page (? string?))
-       ('synopsis (? string?))
-       ('description (? string?))
-       ('license (? symbol?)))
-     (and (member '("libffi" ,libffi) inputs)
-          (member '("gmp" ,gmp) pinputs)
-          #t))
-    (x
-     (pk 'fail x #f))))
-
-(test-end "snix")