summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/databases.scm6
-rw-r--r--gnu/packages/patches/python-alembic-exceptions-cause.patch69
3 files changed, 2 insertions, 74 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index faf9888073..357ec3b7f2 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1453,7 +1453,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/python-CVE-2018-14647.patch		\
   %D%/packages/patches/python-aiohttp-3.6.2-no-warning-fail.patch	\
   %D%/packages/patches/python-aionotify-0.2.0-py3.8.patch	\
-  %D%/packages/patches/python-alembic-exceptions-cause.patch	\
   %D%/packages/patches/python-argcomplete-1.11.1-fish31.patch	\
   %D%/packages/patches/python-axolotl-AES-fix.patch		\
   %D%/packages/patches/python-cairocffi-dlopen-path.patch	\
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index db8b74db06..6c1d95c126 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2703,15 +2703,13 @@ You might also want to install the following optional dependencies:
 (define-public python-alembic
   (package
     (name "python-alembic")
-    (version "1.4.1")
+    (version "1.4.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "alembic" version))
-       (patches (search-patches "python-alembic-exceptions-cause.patch"))
        (sha256
-        (base32
-         "0a4hzn76csgbf1px4f5vfm256byvjrqkgi9869nkcjrwjn35c6kr"))))
+        (base32 "1gsdrzx9h7wfva200qvvsc9sn4w79mk2vs0bbnzjhxi1jw2b0nh3"))))
     (build-system python-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
diff --git a/gnu/packages/patches/python-alembic-exceptions-cause.patch b/gnu/packages/patches/python-alembic-exceptions-cause.patch
deleted file mode 100644
index b9844e5ad0..0000000000
--- a/gnu/packages/patches/python-alembic-exceptions-cause.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-Fix a test failure with newer versions of SQLalchemy due to missing
-"causes" for some exceptions.
-
-diff --git a/alembic/operations/ops.py b/alembic/operations/ops.py
-index 5ec2762..7129472 100644
---- a/alembic/operations/ops.py
-+++ b/alembic/operations/ops.py
-@@ -108,6 +108,7 @@ def from_constraint(cls, constraint):
-             "primary_key_constraint": "primary",
-             "check_constraint": "check",
-             "column_check_constraint": "check",
-+            "table_or_column_check_constraint": "check",
-         }
- 
-         constraint_table = sqla_compat._table_for_constraint(constraint)
-@@ -707,6 +708,7 @@ def batch_create_foreign_key(
-     "create_check_constraint", "batch_create_check_constraint"
- )
- @AddConstraintOp.register_add_constraint("check_constraint")
-+@AddConstraintOp.register_add_constraint("table_or_column_check_constraint")
- @AddConstraintOp.register_add_constraint("column_check_constraint")
- class CreateCheckConstraintOp(AddConstraintOp):
-     """Represent a create check constraint operation."""
-diff --git a/alembic/testing/assertions.py b/alembic/testing/assertions.py
-index 3dc08f0..a78e5e8 100644
---- a/alembic/testing/assertions.py
-+++ b/alembic/testing/assertions.py
-@@ -2,10 +2,9 @@
- 
- import re
- 
-+from sqlalchemy import util
- from sqlalchemy.engine import default
- from sqlalchemy.testing.assertions import _expect_warnings
--from sqlalchemy.testing.assertions import assert_raises  # noqa
--from sqlalchemy.testing.assertions import assert_raises_message  # noqa
- from sqlalchemy.testing.assertions import eq_  # noqa
- from sqlalchemy.testing.assertions import is_  # noqa
- from sqlalchemy.testing.assertions import is_false  # noqa
-@@ -17,6 +16,29 @@
- from ..util.compat import py3k
- 
- 
-+def assert_raises(except_cls, callable_, *args, **kw):
-+    try:
-+        callable_(*args, **kw)
-+        success = False
-+    except except_cls:
-+        success = True
-+
-+    # assert outside the block so it works for AssertionError too !
-+    assert success, "Callable did not raise an exception"
-+
-+
-+def assert_raises_message(except_cls, msg, callable_, *args, **kwargs):
-+    try:
-+        callable_(*args, **kwargs)
-+        assert False, "Callable did not raise an exception"
-+    except except_cls as e:
-+        assert re.search(msg, util.text_type(e), re.UNICODE), "%r !~ %s" % (
-+            msg,
-+            e,
-+        )
-+        print(util.text_type(e).encode("utf-8"))
-+
-+
- def eq_ignore_whitespace(a, b, msg=None):
-     # sqlalchemy.testing.assertion has this function
-     # but not with the special "!U" detection part