summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/node.scm8
-rw-r--r--gnu/packages/patches/node-9077.patch25
2 files changed, 18 insertions, 15 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index cb57415161..40c2b04ab3 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -38,14 +38,14 @@
 (define-public node
   (package
     (name "node")
-    (version "7.8.0")
+    (version "7.10.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://nodejs.org/dist/v" version
                                   "/node-v" version ".tar.gz"))
               (sha256
                (base32
-                "1nkngdjbsm81nn3v0w0c2aqx9nb7mwy3z49ynq4wwcrzfr9ap8ka"))
+                "00vdmb0z8b2sd547bkksgy9dfq5gi5xfd9b3f0rc4ngvpzl3z164"))
               ;; https://github.com/nodejs/node/pull/9077
               (patches (search-patches "node-9077.patch"))))
     (build-system gnu-build-system)
@@ -86,7 +86,9 @@
                          "test/parallel/test-cluster-master-error.js"
                          "test/parallel/test-cluster-master-kill.js"
                          "test/parallel/test-npm-install.js"
-                         "test/sequential/test-child-process-emfile.js"))
+                         "test/sequential/test-child-process-emfile.js"
+                         "test/sequential/test-benchmark-child-process.js"
+                         "test/sequential/test-http-regr-gh-2928.js"))
              #t))
          (replace 'configure
            ;; Node's configure script is actually a python script, so we can't
diff --git a/gnu/packages/patches/node-9077.patch b/gnu/packages/patches/node-9077.patch
index e57f5caac7..6b71d48c0e 100644
--- a/gnu/packages/patches/node-9077.patch
+++ b/gnu/packages/patches/node-9077.patch
@@ -12,19 +12,20 @@ zlib. Using a shared zlib results in build breakage:
                ^ ~~~~~~~~~~~~~~~~~
 1 error generated.
 ---
- node.gyp | 2 ++
- 1 file changed, 2 insertions(+)
+ node.gyp | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
 
 diff --git a/node.gyp b/node.gyp
-index fa98547..d799ba1 100644
+index 272dc98..667c260 100644
 --- a/node.gyp
 +++ b/node.gyp
-@@ -480,6 +480,8 @@
-         }],
-         [ 'node_shared_zlib=="false"', {
-           'dependencies': [ 'deps/zlib/zlib.gyp:zlib' ],
-+        }, {
-+          'defines': [ 'ZLIB_CONST' ],
-         }],
- 
-         [ 'node_shared_http_parser=="false"', {
+@@ -653,7 +653,8 @@
+             [ 'node_shared_zlib=="false"', {
+               'dependencies': [
+                 'deps/zlib/zlib.gyp:zlib',
+-              ]
++              ]}, {
++              'defines': [ 'ZLIB_CONST' ],
+             }],
+             [ 'node_shared_openssl=="false"', {
+               'dependencies': [