summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5d492d073c..9ab75507e5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4873,6 +4873,31 @@ utility, a static analysis tool (linter) for Robot Framework source files.")
     (description "Pabot is a parallel executor for Robot Framework tests.")
     (license license:asl2.0)))
 
+(define-public python-sshtunnel
+  (package
+    (name "python-sshtunnel")
+    (version "0.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "sshtunnel" version))
+              (sha256
+               (base32
+                "1z7rdgpp9m36ysh9pfzrn3vyiaj05bkjvcjdhj8vz0fvfjkhxjz7"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests? (invoke "pytest" "-vv" "tests")))))))
+    (propagated-inputs (list python-paramiko))
+    (native-inputs (list openssh python-pytest))
+    (home-page "https://github.com/pahaz/sshtunnel")
+    (synopsis "Python SSH tunnels library")
+    (description "@code{sshtunnel} is a Python module for easily creating SSH
+tunnels in the background, using Python.")
+    (license license:expat)))
+
 (define-public python-robotframework-stacktrace
   (package
     (name "python-robotframework-stacktrace")