summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/games.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 61eed39ef0..896d53412e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2648,6 +2648,12 @@ Transport Tycoon Deluxe.")
      `(#:tests? #f ;; no tests available
        #:phases
         (modify-phases %standard-phases
+          (add-after 'unpack 'fix-usr-share-paths
+            (lambda* (#:key make-flags outputs #:allow-other-keys)
+              ;; Fix some references to /usr/share.
+              (substitute* "src/openrct2/platform/linux.c"
+                (("/usr/share")
+                (string-append (assoc-ref %outputs "out") "/share")))))
           (add-after 'build 'fix-cmake-install-file
             (lambda _
               ;; The build system tries to download a file and compare hashes.