summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-crypto.scm67
-rw-r--r--gnu/packages/crates-io.scm67
2 files changed, 67 insertions, 67 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 81a0c27986..cca62c314e 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -2510,6 +2510,73 @@ a cipher, can be used as a Message Authentication Code (MAC).")
        #:cargo-development-inputs
        (("rust-hex-literal" ,rust-hex-literal-0.3))))))
 
+(define-public rust-polyval-0.6
+  (package
+    (name "rust-polyval")
+    (version "0.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "polyval" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1iihmpn1h1ag5zl368yfq0jz1drfdw7xg7zpaqpcppqiikh39wky"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-cfg-if" ,rust-cfg-if-1)
+        ("rust-cpufeatures" ,rust-cpufeatures-0.2)
+        ("rust-opaque-debug" ,rust-opaque-debug-0.3)
+        ("rust-universal-hash" ,rust-universal-hash-0.5)
+        ("rust-zeroize" ,rust-zeroize-1))
+       #:cargo-development-inputs
+       (("rust-hex-literal" ,rust-hex-literal-0.3))))
+    (home-page "https://github.com/RustCrypto/universal-hashes")
+    (synopsis "GHASH-like universal hash")
+    (description "POLYVAL is a GHASH-like universal hash over GF(2^128) useful
+for constructing a Message Authentication Code (MAC).")
+    (license (list license:asl2.0 license:expat))))
+
+(define-public rust-polyval-0.4
+  (package
+    (inherit rust-polyval-0.6)
+    (name "rust-polyval")
+    (version "0.4.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "polyval" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1kdpcjhc3666g8xaqichsyf6fhn8rry3z70dqhmvv6hb2jmc9g7f"))))
+    (arguments
+     `(#:cargo-inputs
+       (("rust-cpuid-bool" ,rust-cpuid-bool-0.2)
+        ("rust-opaque-debug" ,rust-opaque-debug-0.3)
+        ("rust-universal-hash" ,rust-universal-hash-0.4)
+        ("rust-zeroize" ,rust-zeroize-1))
+       #:cargo-development-inputs
+       (("rust-hex-literal" ,rust-hex-literal-0.2))))))
+
+(define-public rust-polyval-0.3
+  (package
+    (inherit rust-polyval-0.4)
+    (name "rust-polyval")
+    (version "0.3.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "polyval" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256 (base32 "04m2wf4pk6gglvl12fj7ylc2iqhxmzqj46rds6zy73cpk0a39hvy"))))
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-cfg-if" ,rust-cfg-if-0.1)
+        ("rust-universal-hash" ,rust-universal-hash-0.3)
+        ("rust-zeroize" ,rust-zeroize-1))))))
+
 (define-public rust-ppv-lite86-0.2
   (package
     (name "rust-ppv-lite86")
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index bbc919f5b0..4b991c3dd8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -49673,73 +49673,6 @@ library.")
     (description "Proc-macro crate for pollster.")
     (license (list license:asl2.0 license:expat))))
 
-(define-public rust-polyval-0.6
-  (package
-    (name "rust-polyval")
-    (version "0.6.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "polyval" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "1iihmpn1h1ag5zl368yfq0jz1drfdw7xg7zpaqpcppqiikh39wky"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-cfg-if" ,rust-cfg-if-1)
-        ("rust-cpufeatures" ,rust-cpufeatures-0.2)
-        ("rust-opaque-debug" ,rust-opaque-debug-0.3)
-        ("rust-universal-hash" ,rust-universal-hash-0.5)
-        ("rust-zeroize" ,rust-zeroize-1))
-       #:cargo-development-inputs
-       (("rust-hex-literal" ,rust-hex-literal-0.3))))
-    (home-page "https://github.com/RustCrypto/universal-hashes")
-    (synopsis "GHASH-like universal hash")
-    (description "POLYVAL is a GHASH-like universal hash over GF(2^128) useful
-for constructing a Message Authentication Code (MAC).")
-    (license (list license:asl2.0 license:expat))))
-
-(define-public rust-polyval-0.4
-  (package
-    (inherit rust-polyval-0.6)
-    (name "rust-polyval")
-    (version "0.4.5")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "polyval" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "1kdpcjhc3666g8xaqichsyf6fhn8rry3z70dqhmvv6hb2jmc9g7f"))))
-    (arguments
-     `(#:cargo-inputs
-       (("rust-cpuid-bool" ,rust-cpuid-bool-0.2)
-        ("rust-opaque-debug" ,rust-opaque-debug-0.3)
-        ("rust-universal-hash" ,rust-universal-hash-0.4)
-        ("rust-zeroize" ,rust-zeroize-1))
-       #:cargo-development-inputs
-       (("rust-hex-literal" ,rust-hex-literal-0.2))))))
-
-(define-public rust-polyval-0.3
-  (package
-    (inherit rust-polyval-0.4)
-    (name "rust-polyval")
-    (version "0.3.3")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "polyval" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256 (base32 "04m2wf4pk6gglvl12fj7ylc2iqhxmzqj46rds6zy73cpk0a39hvy"))))
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-cfg-if" ,rust-cfg-if-0.1)
-        ("rust-universal-hash" ,rust-universal-hash-0.3)
-        ("rust-zeroize" ,rust-zeroize-1))))))
-
 (define-public rust-pom-3
   (package
     (name "rust-pom")