summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/compression.scm17
-rw-r--r--guix/scripts/pack.scm4
-rw-r--r--tests/pack.scm4
3 files changed, 4 insertions, 21 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 02e4e324b9..cf23e88547 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -819,23 +819,6 @@ systems where low overhead is needed.  This package allows you to create and
 extract such file systems.")
     (license license:gpl2+)))
 
-;; We need this for building squashfs images with symlinks.
-(define-public squashfs-tools-next
-  (let ((commit "fb33dfc32b131a1162dcf0e35bd88254ae10e265")
-        (revision "1"))
-    (package (inherit squashfs-tools)
-      (name "squashfs-tools-next")
-      (version (string-append "4.3-" revision (string-take commit 7)))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/plougher/squashfs-tools.git")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "1x2skf8hxzfch978nzx5mh46d4hhi6gl22270hiarjszsjk3bnsx")))))))
-
 (define-public pigz
   (package
     (name "pigz")
diff --git a/guix/scripts/pack.scm b/guix/scripts/pack.scm
index bbacc93bc0..9676d28565 100644
--- a/guix/scripts/pack.scm
+++ b/guix/scripts/pack.scm
@@ -319,7 +319,7 @@ to the search paths of PROFILE."
                          entry-point
                          localstatedir?
                          (symlinks '())
-                         (archiver squashfs-tools-next))
+                         (archiver squashfs-tools))
   "Return a squashfs image containing a store initialized with the closure of
 PROFILE, a derivation.  The image contains a subset of /gnu/store, empty mount
 points for virtual file systems (like procfs), and optional symlinks.
@@ -1045,7 +1045,7 @@ Create a bundle of PACKAGE.\n"))
                                   bootstrap-xz
                                   (assoc-ref opts 'compressor)))
                  (archiver    (if (equal? pack-format 'squashfs)
-                                  squashfs-tools-next
+                                  squashfs-tools
                                   (if bootstrap?
                                       %bootstrap-coreutils&co
                                       tar)))
diff --git a/tests/pack.scm b/tests/pack.scm
index 71ff5aec18..0c1406e687 100644
--- a/tests/pack.scm
+++ b/tests/pack.scm
@@ -28,7 +28,7 @@
   #:use-module (guix tests)
   #:use-module (guix gexp)
   #:use-module (gnu packages bootstrap)
-  #:use-module ((gnu packages compression) #:select (squashfs-tools-next))
+  #:use-module ((gnu packages compression) #:select (squashfs-tools))
   #:use-module (srfi srfi-64))
 
 (define %store
@@ -199,7 +199,7 @@
                            (string-append "." #$profile "/bin"))
 
                          (setenv "PATH"
-                                 (string-append #$squashfs-tools-next "/bin"))
+                                 (string-append #$squashfs-tools "/bin"))
                          (invoke "unsquashfs" #$image)
                          (with-directory-excursion "squashfs-root"
                            (when (and (file-exists? (string-append bin