summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/installer/user.scm50
-rw-r--r--gnu/local.mk1
-rw-r--r--po/guix/POTFILES.in1
3 files changed, 52 insertions, 0 deletions
diff --git a/gnu/installer/user.scm b/gnu/installer/user.scm
new file mode 100644
index 0000000000..1f8d40a011
--- /dev/null
+++ b/gnu/installer/user.scm
@@ -0,0 +1,50 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu installer user)
+  #:use-module (guix records)
+  #:export (<user>
+            user
+            make-user
+            user-name
+            user-group
+            user-home-directory
+
+            users->configuration))
+
+(define-record-type* <user>
+  user make-user
+  user?
+  (name            user-name)
+  (group           user-group
+                   (default "users"))
+  (home-directory  user-home-directory))
+
+(define (users->configuration users)
+  "Return the configuration field for USERS."
+  `((users (cons*
+             ,@(map (lambda (user)
+                      `(user-account
+                        (name ,(user-name user))
+                        (group ,(user-group user))
+                        (home-directory ,(user-home-directory user))
+                        (supplementary-groups
+                         (quote ("wheel" "netdev"
+                                 "audio" "video")))))
+                    users)
+             %base-user-accounts))))
diff --git a/gnu/local.mk b/gnu/local.mk
index bcb5e5f679..0b5e96afa4 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -577,6 +577,7 @@ GNU_SYSTEM_MODULES +=                           \
   %D%/installer/services.scm			\
   %D%/installer/steps.scm			\
   %D%/installer/timezone.scm			\
+  %D%/installer/user.scm			\
   %D%/installer/utils.scm			\
 						\
   %D%/installer/newt/ethernet.scm		\
diff --git a/po/guix/POTFILES.in b/po/guix/POTFILES.in
index df7459a4b7..48c09a1e3a 100644
--- a/po/guix/POTFILES.in
+++ b/po/guix/POTFILES.in
@@ -31,6 +31,7 @@ gnu/installer/newt/wifi.scm
 gnu/installer/services.scm
 gnu/installer/steps.scm
 gnu/installer/timezone.scm
+gnu/installer/user.scm
 gnu/installer/utils.scm
 guix/scripts.scm
 guix/scripts/build.scm