summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/compton.scm3
-rw-r--r--gnu/packages/linux.scm3
-rw-r--r--gnu/packages/mail.scm3
-rw-r--r--gnu/packages/text-editors.scm1
-rw-r--r--gnu/packages/version-control.scm10
-rw-r--r--gnu/packages/web.scm12
-rw-r--r--gnu/packages/wm.scm28
7 files changed, 11 insertions, 49 deletions
diff --git a/gnu/packages/compton.scm b/gnu/packages/compton.scm
index a0a644db7b..323807091a 100644
--- a/gnu/packages/compton.scm
+++ b/gnu/packages/compton.scm
@@ -50,7 +50,6 @@
       (build-system gnu-build-system)
       (inputs
        `(("dbus" ,dbus)
-         ("docbook-xml" ,docbook-xml)
          ("libconfig" ,libconfig)
          ("libx11" ,libx11)
          ("libxcomposite" ,libxcomposite)
@@ -58,10 +57,8 @@
          ("libxext" ,libxext)
          ("libxfixes" ,libxfixes)
          ("libxinerama" ,libxinerama)
-         ("libxml2" ,libxml2)
          ("libxrandr" ,libxrandr)
          ("libxrender" ,libxrender)
-         ("libxslt" ,libxslt)
          ("mesa" ,mesa)
          ("xprop" ,xprop)
          ("xwininfo" ,xwininfo)))
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 46052fe10d..86c222f03d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2224,8 +2224,6 @@ in a digital read-out.")
 
        ;; Documentation.
        ("libxml2" ,libxml2)                       ;for $XML_CATALOG_FILES
-       ("libxslt" ,libxslt)
-       ("docbook-xml" ,docbook-xml)
        ("docbook-xsl" ,docbook-xsl)
        ("xmlto" ,xmlto)
        ("asciidoc" ,asciidoc)))
@@ -2803,7 +2801,6 @@ and copy/paste text in the console and in xterm.")
                      ("xmlto" ,xmlto)
                      ;; For building documentation.
                      ("libxml2" ,libxml2)
-                     ("docbook-xml" ,docbook-xml)
                      ("docbook-xsl" ,docbook-xsl)
                      ;; For tests.
                      ("which" ,which)))
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index bd48176c7c..aaf9fce609 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -423,8 +423,7 @@ and corrections.  It is based on a Bayesian filter.")
                 "0i5dvygps1ai2qwgamab8kngrp0c5m3bgaw0jk34l8ypsk54wj8r"))))
     (build-system python-build-system)
     (native-inputs
-     `(("asciidoc" ,asciidoc)
-       ("libxslt" ,libxslt)))  ; for xsltproc
+     `(("asciidoc" ,asciidoc)))
     (inputs `(("python2-pysqlite" ,python2-pysqlite)
               ("python2-six" ,python2-six)))
     (arguments
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 4b6aa07ee8..a093baa3bd 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -137,7 +137,6 @@ based command language.")
                ;; without them the tests fail.
                (zero? (system* "chmod" "-R" "u+w" "../test")))))))
       (native-inputs `(("gcc" ,gcc-5)
-                       ("libxslt" ,libxslt)
                        ("asciidoc" ,asciidoc)
                        ("ruby" ,ruby)))
       (inputs `(("gcc:lib" ,gcc-5 "lib")
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index cce93a2fca..7ade4a4840 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -450,11 +450,7 @@ to lock down your entire repository.")
                     #t)))))))
     (native-inputs
      ;; For building manpage.
-     `(("asciidoc" ,asciidoc)
-       ("docbook-xml" ,docbook-xml)
-       ("docbook-xsl" ,docbook-xsl)
-       ("xmllint" ,libxml2)
-       ("xsltprot" ,libxslt)))
+     `(("asciidoc" ,asciidoc)))
     (inputs
      `(("git:src" ,(package-source git@2.9))
        ("openssl" ,openssl)
@@ -856,10 +852,6 @@ RCS, PRCS, and Aegis packages.")
        (list "CC=gcc" (string-append "prefix?=" (assoc-ref %outputs "out")))))
     (inputs `(("git" ,git)))
     (native-inputs `(("asciidoc"    ,asciidoc)
-                     ("docbook-xml" ,docbook-xml)
-                     ("docbook-xsl" ,docbook-xsl)
-                     ("xmllint"     ,libxml2)
-                     ("xsltproc"    ,libxslt)
                      ;; These are needed for the tests.
                      ("cvs"    ,cvs)
                      ("python" ,python-2)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index a0e76d52c4..7fb94005e8 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -626,11 +626,7 @@ used to validate and fix HTML data.")
         %standard-phases)))
     ;; All of the below are used to generate the documentation
     ;; (Should they be propagated inputs of asciidoc ??)
-    (native-inputs `(("asciidoc" ,asciidoc)
-                     ("libxml2" ,libxml2)
-                     ("docbook-xml" ,docbook-xml)
-                     ("docbook-xsl" ,docbook-xsl)
-                     ("libxslt" ,libxslt)))
+    (native-inputs `(("asciidoc" ,asciidoc)))
     (home-page "https://tinyproxy.github.io/")
     (synopsis "Light-weight HTTP/HTTPS proxy daemon")
     (description "Tinyproxy is a light-weight HTTP/HTTPS proxy
@@ -4479,11 +4475,7 @@ exploit attempts.")
          "0pf91nc0xcykahc3x7ww525c9czm8zpg80nxl8n2mrzc4ilgvass"))))
     (build-system python-build-system)
     (native-inputs
-     `(("asciidoc" ,asciidoc)
-       ("docbook-xsl" ,docbook-xsl)
-       ("docbook-xml" ,docbook-xml)
-       ("libxml2" ,libxml2)             ;for xmllint
-       ("libxslt" ,libxslt)))           ;for xsltproc
+     `(("asciidoc" ,asciidoc)))
     (inputs
      `(("python-colorama" ,python-colorama)
        ("python-cssutils" ,python-cssutils)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 7d76a2d202..b95f2e7a6f 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -177,26 +177,12 @@ commands would.")
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags
-       (let* ((docbook-xsl-name-version ,(string-append
-                                          (package-name docbook-xsl) "-"
-                                          (package-version  docbook-xsl)))
-              (docbook-xsl-catalog-file (string-append
-                                         (assoc-ref %build-inputs "docbook-xsl")
-                                         "/xml/xsl/"
-                                         docbook-xsl-name-version
-                                         "/catalog.xml"))
-              (docbook-xml-catalog-file (string-append
-                                         (assoc-ref %build-inputs "docbook-xml")
-                                         "/xml/dtd/docbook/catalog.xml")))
-         ;; Reference the catalog files required to build the manpages.
-         (list (string-append "XML_CATALOG_FILES=" docbook-xsl-catalog-file " "
-                              docbook-xml-catalog-file)
-              "CC=gcc"
-              (string-append "PREFIX=" %output)
-              ;; This works around the following error:
-              ;; 'error: ‘for’ loop initial declarations are only allowed in C99
-              ;; or C11 mode'
-              "CFLAGS=-std=c11"))
+       (list "CC=gcc"
+             (string-append "PREFIX=" %output)
+             ;; This works around the following error:
+             ;; 'error: ‘for’ loop initial declarations are only allowed in C99
+             ;; or C11 mode'
+             "CFLAGS=-std=c11")
        ;; The build system tries to build in a separate directory, but that
        ;; seems to be unnecessary.
        #:configure-flags '("--disable-builddir")
@@ -215,7 +201,6 @@ commands would.")
        ("asciidoc" ,asciidoc)
        ("xmlto" ,xmlto)
        ("perl-pod-simple" ,perl-pod-simple)
-       ("docbook-xml" ,docbook-xml)
        ("libx11" ,libx11)
        ("pcre" ,pcre)
        ("startup-notification" ,startup-notification)
@@ -226,6 +211,7 @@ commands would.")
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)
        ;; For building the documentation.
+       ("libxml2" ,libxml2)
        ("docbook-xsl" ,docbook-xsl)))
     (home-page "https://i3wm.org/")
     (synopsis "Improved tiling window manager")