summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/debug.scm4
-rw-r--r--gnu/packages/diffoscope.scm2
-rw-r--r--gnu/packages/games.scm2
-rw-r--r--gnu/packages/gnuzilla.scm3
-rw-r--r--gnu/packages/graphics.scm4
-rw-r--r--gnu/packages/linux.scm4
-rw-r--r--gnu/packages/llvm.scm12
-rw-r--r--gnu/packages/opencl.scm3
-rw-r--r--gnu/packages/rust.scm4
9 files changed, 19 insertions, 19 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 3bf7f6a8e0..180fd936ec 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -132,8 +132,8 @@ program to exhibit a bug.")
     (native-inputs (list flex))
     (inputs
      `(("astyle"          ,astyle)
-       ("llvm"            ,llvm)
-       ("clang"           ,clang)
+       ("llvm"            ,llvm-9)
+       ("clang"           ,clang-9)
        ("indent"          ,indent)
        ("perl"            ,perl)
        ("exporter-lite"   ,perl-exporter-lite)
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 743447a9d5..064be354cb 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -186,7 +186,7 @@
              hdf5
              imagemagick
              libarchive
-             llvm
+             llvm-9
              lz4
              mono
              ocaml
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 591a3d3f38..ccc5b3740a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9367,7 +9367,7 @@ play with up to four players simultaneously.  It has network support.")
        ("sdl" ,(sdl-union
                 (list sdl2 sdl2-mixer sdl2-net sdl2-ttf sdl2-image)))))
     (native-inputs
-     (list clang ghc pkg-config qttools))
+     (list clang-9 ghc pkg-config qttools))
     (home-page "https://hedgewars.org/")
     (synopsis "Turn-based artillery game featuring fighting hedgehogs")
     (description
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index a9b5ed9fe9..1ee5248ced 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -567,7 +567,8 @@ in C/C++.")
     (native-inputs
      `(("autoconf" ,autoconf-2.13)
        ("automake" ,automake)
-       ("llvm" ,llvm)                   ;for llvm-objdump
+       ;; TODO(staging): Use the default LLVM in the next rebuild cycle.
+       ("llvm" ,llvm-9)                 ;for llvm-objdump
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)
        ("python" ,python-3)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index b69ab52aec..cc56d9d319 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -618,9 +618,9 @@ more.")
                         "|"))))))))
     (native-inputs
      (list bison
-           clang
+           clang-9
            flex
-           llvm
+           llvm-9
            pybind11
            python-wrapper))
     (inputs
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4d3ff8efd4..e496b5e2b2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8515,7 +8515,7 @@ headers.")
     (native-inputs
      (list bison flex))
     (inputs
-     `(("clang-toolchain" ,clang-toolchain)
+     `(("clang-toolchain" ,clang-toolchain-9)
        ("libbpf" ,(package-source libbpf))
        ;; LibElf required but libelf does not contain
        ;; archives, only object files.
@@ -8595,7 +8595,7 @@ and above.")
     (native-inputs
      (list bison flex))
     (inputs
-     (list bcc clang-toolchain elfutils libbpf))
+     (list bcc clang-toolchain-9 elfutils libbpf))
     (arguments
      `(#:tests? #f ;Tests require googletest sources.
        #:configure-flags
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 83f57ec28e..be93693e2d 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1038,10 +1038,10 @@ of programming tools as well as libraries with equivalent functionality.")
                    #:patches '("clang-3.5-libc-search-path.patch")))
 
 ;; Default LLVM and Clang version.
-(define-public llvm llvm-9)
-(define-public clang-runtime clang-runtime-9)
-(define-public clang clang-9)
-(define-public clang-toolchain clang-toolchain-9)
+(define-public llvm llvm-13)
+(define-public clang-runtime clang-runtime-13)
+(define-public clang clang-13)
+(define-public clang-toolchain clang-toolchain-13)
 
 (define-public llvm-for-rocm
   (package
@@ -1389,7 +1389,7 @@ standard C++ library.")
          (add-after 'unpack 'chdir
            (lambda _ (chdir "libclc") #t)))))
     (native-inputs
-     (list clang llvm python))
+     (list clang-9 llvm-9 python))
     (home-page "https://libclc.llvm.org")
     (synopsis "Libraries for the OpenCL programming language")
     (description
@@ -1418,7 +1418,7 @@ requirements according to version 1.1 of the OpenCL specification.")
                            "-DOPENMP_TEST_CXX_COMPILER=clang++")
        #:test-target "check-libomp"))
     (native-inputs
-     (list clang llvm perl pkg-config))
+     (list clang-9 llvm-9 perl pkg-config))
     (inputs
      (list `(,hwloc "lib")))
     (home-page "https://openmp.llvm.org")
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index 940f52587e..3539c47d66 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -290,8 +290,7 @@ back-end for the LLVM compiler framework.")
     (native-inputs
      (list libltdl pkg-config))
     (inputs
-     (list clang
-           `(,hwloc-2 "lib") llvm opencl-icd-loader))
+     (list clang-9 llvm-9 `(,hwloc-2 "lib") opencl-icd-loader))
     (arguments
      `(#:configure-flags
        (list "-DENABLE_ICD=ON"
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 5a6d4a5c30..26d6df7a94 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -165,7 +165,7 @@
     (inputs
      `(("libcurl" ,curl)
        ("libssh2" ,libssh2)
-       ("llvm" ,llvm)
+       ("llvm" ,llvm-9)
        ("openssl" ,openssl)
        ("zlib" ,zlib)))
     (native-inputs
@@ -493,7 +493,7 @@ ar = \"" binutils "/bin/ar" "\"
        ("which" ,which)))
     (inputs
      `(("jemalloc" ,jemalloc)
-       ("llvm" ,llvm)
+       ("llvm" ,llvm-9)
        ("openssl" ,openssl)
        ("libssh2" ,libssh2)             ; For "cargo"
        ("libcurl" ,curl)))              ; For "cargo"