summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/documentation.scm3
-rw-r--r--gnu/packages/patches/python-docrepr-fix-tests.patch16
3 files changed, 19 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index df294564df..6e97c3a6a6 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1683,6 +1683,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/prusa-slicer-with-cereal-1.3.1.patch	\
   %D%/packages/patches/pthreadpool-system-libraries.patch	\
   %D%/packages/patches/python-chai-drop-python2.patch		\
+  %D%/packages/patches/python-docrepr-fix-tests.patch		\
   %D%/packages/patches/python-feedparser-missing-import.patch	\
   %D%/packages/patches/python-louvain-fix-test.patch		\
   %D%/packages/patches/python-random2-getrandbits-test.patch		\
diff --git a/gnu/packages/documentation.scm b/gnu/packages/documentation.scm
index bbaa01e392..be64bc4f95 100644
--- a/gnu/packages/documentation.scm
+++ b/gnu/packages/documentation.scm
@@ -296,7 +296,8 @@ objects.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1ma5gwy93m1djd3zdlnqfrwhgr8ic1qbsz5kkrb9f987ax40lfkd"))))
+                "1ma5gwy93m1djd3zdlnqfrwhgr8ic1qbsz5kkrb9f987ax40lfkd"))
+              (patches (search-patches "python-docrepr-fix-tests.patch"))))
     (build-system python-build-system)
     (arguments
      (list
diff --git a/gnu/packages/patches/python-docrepr-fix-tests.patch b/gnu/packages/patches/python-docrepr-fix-tests.patch
new file mode 100644
index 0000000000..a209921025
--- /dev/null
+++ b/gnu/packages/patches/python-docrepr-fix-tests.patch
@@ -0,0 +1,16 @@
+Fixes the errors with use of asyncio in docrepr/tests/test_output.py:
+     
+>       await compare_screenshots(test_id, url)
+E       TypeError: 'coroutine' object is not callable
+
+--- a/conftest.py
++++ b/conftest.py
+@@ -65,7 +65,7 @@ def _open_browser(url):
+ 
+ 
+ @pytest.fixture
+-async def compare_screenshots(request):
++def compare_screenshots(request):
+     """Run visual regression test on the output."""
+     async def _compare_screenshots(test_id, url):
+         if (request.config.getoption(COMPARE_SCREENSHOTS_OPTION) or